Latest news link stopped working


#1

Hello,

Great theme! When I first set it up to re-do my site about a week or so ago, the “latest posts” widget worked like a charm to display my portfolio. Today, I realized that 3 out of the 4 links are no longer working. Here’s how it’s set up:

On my homepage (www.nilesmedia.com), I used the page builder to make a row with three latest news widgets, one under the other, each being set to a different category of my blog posts, which is how I display my portfolio according to the different mediums I work in. Under that, another row contains one more “latest news” widget, which pulls from my posts that are actually intended as a blog. The slugs for the categories I want each widget to display work correctly — each widget is pulling the most three recent posts according to the category I set the widget to. And the text to which I changed the “see all our news” button also is reflected. Initially, that button brought you to a page of all my posts (or portfolio samples) in each category.

But today, none of the portfolio links works. All just re-load the home page. The button for the blog posts, however, does bring you to a page full of my blog posts.

When I type in the URL that I think the portfolio buttons should lead to (http://nilesmedia.com/category/medium/car, http://nilesmedia.com/category/medium/audioradio/, http://nilesmedia.com/category/medium/writing), all of them work. And that’s what the respective buttons used to lead to. I’m not sure what could have broken those links, but I’d sure appreciate any help sorting it out!

Thank you,
Hilary


#2

Hi,

If you mean the " See more data projects " button for example, I have inspected it and it’s not linked nowhere, so link the button where you have set it up, so then it will work.

Best Regards,
Csaba


#3

Hi,

Thanks for your reply. I must have accidentally changed something, and then forgotten where a setting is. You said to “link the button where you have it set up” … but I am not seeing where to do that. Unless I’m staring right at it blindly, I don’t see it in the “latest news” widget where I set up that data projects section, for example.

Thank you!
HN


#4

Hi,

That have to be the all-news widget or below it, if you can’t find, please send an admin access / link to your site to me in email at csaba.athemes@gmail.com so I can check it out.

Best Regards,
Csaba


#5

Thanks, Csaba. I sent you an email last night …

HN


#6

Hi,

I have checked your site and some of your buttons have not worked, because you have added as slug medium/slug-name, but by removing medium/ and the / after the slug name it made the buttons to work, please check this on your site and let me know how it works now and if you find a button which is still not working, then, please post a link to it here, so I can check.

Best Regards,
Csaba


#7

Thank you, thank you, thank you!

That seems so obvious now. But yes, because my categories are nested, I had used the full combination of slugs that follows “category” in the URL I was trying to direct to. But of course, I only needed to list the final category I wanted to highlight. It’s all better now.

Thanks again! I really appreciate your responsiveness.

All best wishes,
Hilary


#8

Hi,

Great! You’re most welcome! I’m glad it’s all working now. If you need help with anything else, please, feel free to open a new topic.

Have a nice day!

Best Regards,
Csaba


#9

Hello!

I am having a similar issue but I have checked my categories are correct.

Any other recommendations?

Thanks!


#10

Hi @inigoysmln,

Please clarify your issue and also, please post a link to your website, so I can check.

Kind Regards,
Csaba


#11

Thanks Csaba.

I have configured the latest news widget in my home page. I have added the slug for all the categories but one that I don’t want to show. When I click in the button to see all, it reloads the home page again. When I remove all the slugs it works. I have made sure the slugs are fine as I copied them from the categories page. I have also made sure there is a page assigned to posts which there is.

My site is itisridingtime.com


#12

Hi,

The button isn’t linked, so that’s why it just reloads the page, please set the button link too, or if you can’t then please deactivate all of your third-party plugins and remove / revert from your custom coding ( if you’ve done any ).

Kind Regards,
Csaba


#13

Hello Csaba,

thanks for the reply. The button is definitely link. I can see it in the Homepage settings. Is there maybe another way to link it?

I have replied this settings but still doesn’t work? As I mentioned, it works if I remove the slug for categories so I find it quite weird.

40

Thanks


#14

Hi,

Please give me an admin access to your website in a Private Reply, so I can check.

Kind Regards,
Csaba


#15

Hello Csaba,

I am a bit reluctant to give anyone admin rights. If you suggest me where to look maybe I can have a look?

Thanks


#16

Hi,

From your screenshots the settings are looking good, so I may have to personally inspect your settings / website, that’s why I’ve asked for the admin access, don’t worry about it, I am here to help you and it is safe to send the admin access in a Private Message.

Kind Regards,
Csaba


#17

Hello Csaba,

I found what the problem is. The widget seems to be designed to work with one category slug or none. As soon as I add more than one the button stops being linked to anything. With one category it works great.

A workaround I can think about is that the link could be manually entered by the user like in other widgets you provide? This would fix the issue.

Thanks!


#18

Hi,

Yes, you are right I tested this on my test site with multiple categories and the button link didn’t worked, I will assign this topic to the development team, so they can fix this issue.

Kind Regards,
Csaba


#20

Hello,

Thanks for checking Csaba. That is great news, I hope this feature is developed as it would ve great :slight_smile:

Quick question, do you know if using the widget in different pages is okay? I am concern it displays the wrong things due to the way it is developed.

Thanks again!