Issues when trying to link buttons to anchors

Hi,

I am setting up a website using Sydney Pro for the first time. I have added your contact form into the footer, and want to add buttons that link to the contact form, which when pressed make the page scroll smoothly down to the top of the form. I have followed instructions here but am still having problems: http://docs.athemes.com/article/127-setting-anchors-talon

The problems I am having when attempting this are as follows:

On large screen size, where the header is ‘sticky’, the button scrolls past the top of the form title (even though I am linking to the container ID, and it works fine on smaller screens when the menu is not sticky).

The button on the header slideshow scrolls smoothly, but if I add a button further down the page using a widget, it jumps rather than scrolls down the page (and jumps past the form title when the menu is ‘sticky’).

You can see the issues here: http://www.hivelearning.net/ - the buttons in question are in the slider at the top of the page and about halfway down the home page.

Any help greatly appreciated!

Thanks

John

Hello John,

  1. Please try to use the following CSS code.

You can add CSS code in Dashboard → Appearance → Customize → Additional CSS (WordPress 4.7 and up).

@media (min-width: 1025px) {
    #sow-contact-form-2 {
        padding-top: 110px;
        margin-top: -110px;
    }
}
  1. Please check this topic:
    https://athemes.com/forums/topic/problem-with-smooth-scrolling-after-installed-the-1-34-version-of-the-theme/

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

Brilliant - tried both of those, and both issues solved. Thanks. :slight_smile:

Great! You are welcome John! :slight_smile:

Kind Regards, Roman.