Intro FP: Latest posts

I wold like to customize a little the “Intro FP: Latest posts” plugin
Not sure what CSS classes are availabel or what they do.
Please let me know how to:

  1. show more than 3 posts, say, the latest 6 posts.
  2. include the date of the post
    Thanks!
    LJL

Hi,

Please follow these step below to:

  1. create child theme

  2. duplicate widgets/fp-latest-posts.php to the child theme

  3. open and edit fp-latest-posts.php and change this line (THIS FOR 1ST QUESTION)
    'posts_per_page' => 3 to 'posts_per_page' => 6

  4. add this line <?php intro_posted_on( ); ?> after this line (THIS FOR 2ND QUESTION)
    <?php the_title( sprintf( '<h5 class="entry-title">'), '</h5>' ); ?>

  5. open functions.php in your child theme and add this line:

if ( function_exists('siteorigin_panels_activate') ) {
  require_once get_template_directory() . "-child/widgets/fp-latest-posts.php";
}
  1. activate your child theme and usually your site will go blank. To fix this, open functions.php in your parent theme, change this line:
    require get_template_directory() . "/widgets/fp-latest-posts.php";
    to
    // require get_template_directory() . "/widgets/fp-latest-posts.php";

That’s it! let me know if you have problem

It did not work.
Got warning error.
LJL

Warning: require_once(/customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro-child/widgets/fp-latest-posts.php): failed to open stream: No such file or directory in /customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro/functions.php on line 4 Fatal error: require_once(): Failed opening required ‘/customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro-child/widgets/fp-latest-posts.php’ (include_path=’.:/usr/share/php’) in /customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro/functions.php on line 4

Warning: require_once(/customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro-child/widgets/fp-latest-posts.php): failed to open stream: No such file or directory in /customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro-child/functions.php on line 4 Fatal error: require_once(): Failed opening required ‘/customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro-child/widgets/fp-latest-posts.php’ (include_path=’.:/usr/share/php’) in /customers/3/2/8/livejazzlounge.com/httpd.www/testsite/wp-content/themes/Intro-child/functions.php on line 4

Hi,

Please follow the steps in above.
Seems like the error message are caused because you are didn’t duplicate the fp-latest-posts.php from parent theme to the child theme (Step #2).

Please make sure you create “widgets” directory in child theme and duplicate fp-latest-posts.php to those directory

Thanks, it worked now.
Didnt think about the widegts directory.
Thanks.
LJL

Please look here:
http://testsite.livejazzlounge.com/latest/
How do I add some space between the posts?
Thanks,
LJL

How do I add some space between the rows of posts?
Thanks,
LJL

Hi,

Please try this code:

.page-id-4977 #blog .columns {
    margin-bottom: 25px;
}

Strange behavior with 6 posts:
http://testsite.livejazzlounge.com/latest/
Why are those holes there?

Increasing the margin bottom does not help.

Some posts leave a blank space below and some don’t.
I don’t understand why.

We need to resize the thumbnails displayed on this page, reduce their height just a tiny bit, may be acouple of pixels. Where does the plug in pull the image sizes from? How can we change this?
Thanks.
LJL

When the featured imgae is 500x500 (as all images I have are) then it leaves a blank below. If the image is 500x498 it works. Even though the thumbnail display is scaled down to 300px across. I dont understand this. I cant possible chnage all 650 images in the site.

How can this be fixed?

Thanks!

LJL