Internet Explorer 11 Problems

Hi there,

I just LOVE the West theme, it is in my mind the best and easiest to use. However, I have built my site and now discovered that it does not render correctly on IE11. The animated sections are all weirdly placed and makes it look horrible.

http://bv.preferredsolutions.co.za

Please help! I really like the animations and don’t wat to disable it just because IE11 is being stupid.

Hi,

I see what you mean but this is something you’d have to ask the Live Composer’s devs since those animations come from the plugin and they might need to update the plugin if there’s an issue.

Hi. Okay I will go that route and post what they have said here, just to keep the other users on this theme informed on the solution.

So this is what Live Composer replied … however this CSS does not fix the problem. Can you help?

…We didn’t invest too much time for this compatibility. We are a small team and working hard to add new features to the plugin. The animations are the not most used feature from our plugin. Until we manage to improve this for IE, please use the following CSS snippet to disable the animations on IE:

.win.gecko .dslc-in-viewport-anim-dslcSlideRightFadeIn.dslc-in-viewport-check, .win.gecko .dslc-in-viewport-check.dslc-in-viewport-anim-dslcSlideLeftFadeIn { transform: none !important; }

Try this modified version of their code please:


.win.gecko .dslc-in-viewport-anim-dslcSlideDownFadeIn.dslc-in-viewport-check, .win.gecko .dslc-in-viewport-check.dslc-in-viewport-anim-dslcSlideUpFadeIn {
    transform: none !important;
}

Totally worked!I have looked over this a few time and cannot find a difference in what you posted to what they posted, but somehow yours works!

Thank you so much! I am sure this will help many others not even aware of this problem yet.

The difference is in the animation classes: dslcSlideDownFadeIn and dslcSlideUpFadeIn. They gave you for left/right animations but yours are up/down.
I’m guessing you had different animations on your website when they checked.

I am currently having the same problem after fixing it several months back.

Due to recent updates to Live Composer this kind of CSS code will no longer prevent this issue.

Check the following link for updates:

The issue may be fixed at some point, but not sure when.