Impossible to setup the front page


#1

Hello dear aThemes,

I am facing this problem since I installed the theme. I even deleted all the website and uninstalled wordpress, then installed again in order to fix the problem, but I still have it on my site.
As mentioned in the video tutorial I followed the steps and put the front page as my front page, but after saving it, I open my website in a new tab and it shows the Home page instead of the front page. I tried again and put the front page as my front page and then after saving and publishing it again shows -select-, as if I didnt choose it ever. I am so frustrated I dont know how to solve this. Please help me with that.
Here is my website: www.armfem.com


#2

Hello @karastak,

Can you please try to follow these steps one by one (even if you did it before):
Go to your Dashboard -> Settings -> Reading -> set “Front page displays” to “A static page (select below)” -> choose a page for “Front page:” -> then scroll down and click Save Changes.

After that please make sure that page you set contains the content that you want to display.

Also try to set “Posts page:” to “–Select–” (to turn it off) and see if it changes anything.

Hope it helps.

Sincerely, Roman.


#3

Roman,
thank you for your support. I did as you suggested and after I clicked save, wordpress gave me following notification: The selected page must be translated in all languages. Which means I should translate the front page into all languages I installed and then it will let me set it as a homepage. Thank you again for your help.


#4

You are welcome!

Please feel free to ask any other questions you might have in future.

Best Regards, Roman.