Images not loading when using https


#1

HI

Whenever I connect to my website through http:// everything loads fine & I have no problems. Whenever I connect through https:// the website logo & image slider only sometimes load. It sometimes takes a few refreshes for them to appear. Not quite sure if this is a theme problem or a problem with my hosting, but any help, or a point in the right direction would be very much appreciated.

Many thanks.
Jonny…


#2

Hello Jonny,

Can you please provide a link to your website?

Kind Regards, Roman.


#3

Sorry should have attached it to my original post. The website is …
https://www.carrickjuniorgateway.org.uk/


#4

Hello Jonny, thank you for the link.

I’ve just checked your website, your images are still loading through http, so please try to reupload your images and see if it helps.

Kind Regards, Roman.


#5

Thank you very much for your reply Roman. I have deleted & re-uploaded both images but they are still giving me trouble whenever I connect via https:// Please see attached screenshot…

Many thanks.
Jonny…


#6

Jonny, does your URL contain https in Settings → General section?

Kind Regards, Roman.


#7

It did contain https, but I changed it to http after I received a good few messages about those images not loading.

Many thanks.
Jonny…


#8

So is your issue already resolved?

Kind Regards, Roman.


#9

Only slightly resolved. Now that I have changed the wordpress & site url back to http the website automatically loads the http version where everything loads fine & I’m happy with that. However I have the chairperson and a few committee members who want me to get https fully working properly and use that over http. As per the screenshot posted above the https site doesn’t load the website logo & image slide most of the time.

Many thanks.
Jonny…


#10

Jonny, you can try to follow this extensive tutorial:

Kind Regards, Roman.


#11

Through that link you provided I found Really Simple SSL. I installed the plugin and everything appears to be loading now when connecting via https. I think everything is now sorted. Thank you very much for your help :smiley:

Many thanks.
Jonny…


#12

Great! You are welcome Jonny :slight_smile:

Kind Regards, Roman.


#13