Image size in post - Astrid

I set my posts to full width, but so far the largest image size I can display seems to be 640 px wide.
How can I have insert (multiple) images at for example 800 or 1000 px wide?
Thank you!
Posting the link to one of the posts to show an example.

http://julieverlindenphotography.com/puppy-love-photoshow/

Hello @juliekever,

Can you please try to disable Jetpack plugin and try to insert large image once again?

Kind Regards, Roman.

Thank you so much Roman,

That did the trick. I now get the option ‘full size’ in the image options, so if i upload them at for example 1200 px wide, they will be displayed much better (for photoblog purposes).

Thanks again, easy fix :slight_smile:

Julie

You are welcome Julie! :slight_smile:

By the way, you can try to activate Jetpack plugin but turn off its Photon feature in settings (Appearance tab).

Kind Regards, Roman.