Image size in categories

Hi there.

i use your theme for my blog and I like it a lot. as my frontpage i use the latest blogs options and i can select in the theme options what size the pictures should be.
I set it to large, which makes the images 100% of the content column, which is what i want.

if i now open up a categorie, to show the posts in this categorie, for example travel:
it shows me the small images to the left of the excerpt of the post.
how can I change that it also shows the big images and the same for search view. Because search isnt showing any pictures at all.

Link to the site:

www.gatetoadventures.com

You can use this to make it look the same on categories:


.archive .entry-thumb {
    width: 100%;
    padding: 0;
}
.archive .post-content {
   width: 100%;
}  

You cannot show the images on the search page, not unless you have a child theme to do some small changes.

Thanks Vlad,

that worked perfectly.

What changes would I have to make on a child theme for the search view and is there a good tutorial to read up on how to set up the child theme?

You can see the official Codex page: http://codex.wordpress.org/Child_Themes
After that you just need to copy content.php from the parent theme, paste it to your child theme and rename it to content-search.php. You don’t need to make code changes.

Ok,
i was reading up on this and have one more question, what is the right syntax to include all the css of the parent theme?
There is style.css in the theme root but there is also a css folder with a couple os css files.

I used that for my functions.php to make the parent a depandancy, is this the best way?

add_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’ );
function theme_enqueue_styles() {
wp_enqueue_style( ‘parent-style’, get_template_directory_uri() . ‘/style.css’ );
wp_enqueue_style( ‘child-style’,
get_stylesheet_directory_uri() . ‘/style.css’,
array(‘parent-style’)
);
}

You don’t need to worry about the other css files, those are loaded from the parent theme.

I will try that,

but i checked in live preview i have to set all my settings again. :frowning: well it has to be done :wink:

a question, how can i prevent the header images from being saved again, since I dont crop them and use the full picture, but they still get saved as a copy of the pictures i already uploaded for posts.

Now i have a duplicate just for the header images, which is the same size and everything. Is there a way to skip cropping and just add the pictures as it is…

I found a style issue.

I activated the child theme now, but the site title and slogan is now marked with a weird blue color, which i havent set and its also underlinded.

Same for all the menu items., they are underlined now and i would like to have it back as in the original parent theme.

if i hover over the site title it doesnt chane only the mouse pointer changes not the text.
and i dont want nothing to be underlined now… any ideas?

Another problem with the child theme:
wordpress comments dont show up anymore or at least the pingbacks disappear…

I thinks this whole child theme gives me more trouble as it really fixes

About the header image again. Sometimes it gives me the button “skip cropping” but I dont know why only sometimes…

Change add_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’ ); to this add_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’,99 ); for the links. Skip cropping is the way to go. Don’t know why it doesn’t show up all the time.
All settings must be re-done when you activate a child theme, that’s how Wordpress works.
If you haven’t done any other changes from inside the child theme then it shouldn’t affect the comments.

Ok changed it, but this arises new issues:

my functions.php looks like this now:

<?php
add_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’,99 );
function theme_enqueue_styles() {
wp_enqueue_style( ‘parent-style’, get_template_directory_uri() . ‘/style.css’ );
wp_enqueue_style( ‘child-style’,
get_stylesheet_directory_uri() . ‘/style.css’,
array(‘parent-style’)
);
}

the underlining of the words is gone, which is perfect, but now the text and everythign uses the default color, which is set when the theme is first installed, its kinda red.

I set all the colors to blue, and they are still set under appereance -> customize to blue but frontend is all red.

comments are still not showing up. I havent modified anything else. just what you told me to do. coyping the content and renaming it to have the layout on the search site.

if i activate the parent theme the commetns work just fine.
Update: got the comments fixed by copying comments.php from parent theme to child theme.
but thats not a good solution, because i will have to copy it over and over again, with every themeupdate, and probably will forget to do so, just to stay updated.

Still having the issue with “skip cropping”…

You’ve set the colors to blue from your child theme? Not sure what’s happening with the comments, but anyway you don’t have to worry about updates because they don’t affect your child theme. And the comments.php file will probably never be changed.

You’ve set the colors to blue from your child theme? Not sure what’s happening with the comments, but anyway you don’t have to worry about updates because they don’t affect your child theme. And the comments.php file will probably never be changed.

yeah i have set the colors to blue on parent and well as child theme.

the color first changed after your recent change you told me to do.

dd_action( ‘wp_enqueue_scripts’, ‘theme_enqueue_styles’,99 );

Once I set it back to the original value, it takes the blue colors i have set it to. This seems to force the default color, no matter what i set it to

hi vlad,

could you check whats happening with the color issue? it only happesn if i set your value 99. without it, the color is right but everythign else is not quiet right.

i figured out a temporarly solution in the mean time. I reverted the change with adding the ,99 to the functions.php

and copied all the contend or the original style.css to the style.css of the child theme.

so far it seems to work.

but that is not a good solution i guess. Any better suggestions, why it wont take the values set in the theme customizer…

btw:

how can i change the color of the search button? this one is always red even if i changed all the color values in the theme customizer section.

We’ll see tomorrow. Im mobile until then.