Image requested over HTTPS, but requested an insecure images

Hi,

Im using Sydney and using SSL. However, when for example visiting home page, it throws me not a green key. After checking i found out google say Image requested over HTTPS, but requested an insecure image.

It are images in the wp-content/uploads folder, also standard images from ur demo content.

I’ve tried different plug-ins, which didnt work as fix.
Such as :

  • Force HTTPS
  • Really Simple SS
  • WP Force HTTPS

Is it possible its somewhere in the codes what need to be changed into https, while when viewing images normally, it redirect me to https.

Hi,

Please post a link to your website, so I can check.

Kind Regards,
Csaba

https://www.buurtpreventiependrecht.nl is our website, it seems in Firefox its semi locked, no warning in IE.

Hi,

You have around 10 images that aren’t loaded over https, that’s why you’ve got those errors, please try this plugin and let me know how it works: https://wordpress.org/plugins/https-redirection/

Kind Regards,
Csaba

Ive installed the pugin, but did not solve it.
Ive put settings on whole domain incl image files.

Hi,

Now I can see only this image is loaded via http: http://demo.athemes.com/sydney-temp/wp-content/uploads/sites/80/2018/05/urban-438393_1280.jpg, please try to redirect the link to https://demo.athemes.com/sydney-temp/wp-content/uploads/sites/80/2018/05/urban-438393_1280.jpg which also works.

Kind Regards,
Csaba

That image will be changed soon into another one. Then all should then be all right.

Hi,

Ok, please let me know after the image was replaced.

Kind Regards,
Csaba

Ive fixed the issue. I had to re-upload the images from media libary into elementor editor. Now its fixed (except .js files, but seems no warning given)

Hi,

Great! I’m glad it’s resolved! If you need help with anything else, please open a new topic.

Have a nice day!

Kind Regards,
Csaba