I click "Click to begin" it doesn't scroll down enough

I love your wonderful theme.
I have a problem that when I click “Click to begin” it doesn’t scroll down enough and I can see the header image.
Please tell me how to resolve.
My site is: https://mudanasi.com

Best Regards,

Hello,

Try to use the #content ID instead of #primary. You can change it in the Customize → Header area → Header Slider section. Please feel free to ask any other questions that you might have.

Kind Regards, Roman.
aThemes Support

Hello,

Thank you Roman.
On mobile and iPhone, scrolling is not enough.
Please give me your favor.
How should I set the #content ID?

Best Regards,

Hello, try to use the following CSS code.

You can add CSS code in Customize → Additional CSS section.

#content {
    margin-top: 60px;
}

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.
aThemes Support

Hello, Roman

Thanks to your advice, the PC site has improved.
Thank you.
But as you told me,

content {

Margin-top: 60px;
}
I entered, but there is no change on the iPhone.
Even if you click “Click to begin”, which is the default setting, there is not enough distance for scrolling downward as shown in the photo.

Is there any other way to deal with it?

Best Regards,

Hello,

I don’t see that code currently applied on your website, how exactly did you add it?

Kind Regards, Roman.
aThemes Support

Hello, Roman

What does the code mean?
What do you want to check?
Please kindly advise.

Best Regards,

What does the code mean?

Do you mean the CSS code I posted above?

What do you want to check?

I want to make sure that you have added that CSS code correctly.

I see that you have the WP Fastest Cache plugin activated, you can try to deactivate it.

Kind Regards, Roman.
aThemes Support

Thank you for your reply.

The CSS I added using the child theme is as follows.

/ * Smartphone hamburger menu
-------------------------------------------------- ------------ * /

@media only screen and (max-width: 767px) {
.site-header .col-xs-12 {
width: 50%;
}
.site-header .col-xs-12: nth-of-type (1) {
text-align: left;
}
.site-header .col-xs-12: nth-of-type (2)> div {
margin-top: 0px;
margin-right: 15px;
}
}

@media (min-width: 767px) {
.scroll_head .description_wrap,
.scroll_head .siteHeader_logo {
display: block;
}
.slide-inner {
margin-top: 0! important;
}
.page-header {
top: 0! important;
margin-bottom: 0! important;
}
}


@media only screen and (max-width: 767px) {
  # mainnav-mobi {
 Margin-left: -50%;
 Width: 150%;
  }
}

* /

/ * Lower slider lacks scrolling
-------------------------------------------------- ------------ * /

#content {
    margin-top: 60px;
}

* /

The following code is also added using “TC Custom JavaScript”.

jQuery (function ($) {
$ ('. mainnav a [href * = "#"], a.roll-button [href * = "#"], .smoothscroll [href * = "#"]'). on ('click', function ( e) {
var target = this.hash;
var $ target = $ (target);

if (matchMedia ('only screen and (max-width: 1024px)') .matches) (
offsetScroll = 0;
} else {
offsetScroll = 70;
}

if ($ target.length) {
e.preventDefault ();
$ ('html, body'). stop (). animate ({
'scrollTop': $ target.offset (). top-offsetScroll
}, 1900, 'swing');
It's a sequel.
if ($ ('# mainnav-mobi'). length) $ ('# mainnav-mobi'). hide ();
return false;
}
});
});

And I disabled “WP Fastest Cache”.
The result does not change.
I would like to ask you for your guidance.

Best Regards,

Can you please try to add the code that I mentioned above in CustomizeAdditional CSS section?

Kind Regards, Roman.
aThemes Support

Hello, Roman

I added only the following code to sydney-child in Customize → Additional CSS section.

/ * Smartphone hamburger menu
-------------------------------------------------- ------------ * /

@media only screen and (max-width: 767px) {
.site-header .col-xs-12 {
width: 50%;
}
.site-header .col-xs-12: nth-of-type (1) {
text-align: left;
}
.site-header .col-xs-12: nth-of-type (2)> div {
margin-top: 0px;
margin-right: 15px;
}
}

@media (min-width: 767px) {
.scroll_head .description_wrap,
.scroll_head .siteHeader_logo {
display: block;
}
.slide-inner {
margin-top: 0! important;
}
.page-header {
top: 0! important;
margin-bottom: 0! important;
}
}

/ * Lower slider lacks scrolling
-------------------------------------------------- ------------ * /

#content {
margin-top: 60px;
}

  • /

Also, the description of “TC Custom JavaScript” has been deleted.

I did it exactly as you said, but I can’t see any improvement.
Just in case, I attach an image.

Best Regards,

Hello,

Please leave only this CSS code in CustomizeAdditional CSS section:

#content {
    margin-top: 60px;
}

Kind Regards, Roman.
aThemes Support

Hello, Roman

I just entered the following code as you told me:
Unfortunately, as shown in the attached image, there was no improvement on mobile. (As I told you the other day, it is improving on the PC site)

Furthermore, the arrow is not displayed on the square button at the bottom right of the screen to return to the mobile site of the second image (IMG_1661.PNG).
If you have any CSS code that you can easily modify, please let me know.

Best Regards,

Hello,

You can try to deactivate all your plugins except Elementor, activate the parent theme, and see if it helps. And please use 60px, not 40.

Kind Regards, Roman.
aThemes Support

Hello, Roman

I followed your advice but couldn’t improve it.
Plugins other than Elementor are also disabled.
Is there any other good way to do it?

Best Regards,

Thank you, Roman

The problem of scrolling down after removing the child theme, removing sydney and reinstalling was resolved.
Is it better not to use child themes?

the arrow is not displayed on the square button at the bottom right of the screen to return to the mobile site of the second image (IMG_1661.PNG).

Best Regards,

Hello,

Is it better not to use child themes?

I think that it’s definitely better to use them, but you have to code them properly.

I’m not sure what exactly are your current issues, can you please specify them?

Kind Regards, Roman.
aThemes Support

Hello, Roman

Thank you for the valuable information on the child theme.
Reinstalling the theme sydney and not using any child themes now my site is working fine.

The current remaining problem is as the second piece ((61) .png) of the attached image,
It means that the mark like “^”, which should be in the small rectangle at the bottom right of the screen to return to the upper part of the site, is not displayed.

If you have any information please let me know

Best Regards,

Hello,

There should be an SVG icon, but your footer.php file still contains the code for Font Awesome icon (default in old Sydney versions). Are you sure that your footer.php file is updated?

Kind Regards, Roman.
aThemes Support

Hello, Roman

I am using filezilla to write mudanasi.com/wp-content/themes/sydney/footer.php as follows.

______________

<?php
/**
 * The template for displaying the footer.
 *
 * Contains the closing of the #content div and all content after
 *
 * @package Sydney
 */
?>
			</div>
		</div>
	</div><!-- #content -->

	<?php do_action('sydney_before_footer'); ?>

	<?php if ( is_active_sidebar( 'footer-1' ) ) : ?>
		<?php get_sidebar('footer'); ?>
	<?php endif; ?>

    <a class="go-top"><i class="fa fa-angle-up"></i></a>
		
	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info container">
			<span style="color: #999999;"><center>Copyright &copy; 2016-<?php echo date('Y'); ?> Triple Win Co., Ltd.</span>
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

	<?php do_action('sydney_after_footer'); ?>

</div><!-- #page -->

<?php wp_footer(); ?>

</body>
</html>

_____________

Please give me a code to improve it.
Best Regards,