I can not see my blog (post)

I am using your theme and really like it. I converted my webpage from another WP-theme and almost everything looks great. Except that I cannot see my blog. I would like to add a button on the topsider next to the home button saying “blog”. How do I see all my posts without having to select “static frontage” (if I do that I can see all the posts and they are all under the “home” button but then I do not have the slider which I really want to have) Can you pls help? Thank you!

Sorry, this would not be possible without setting a front page and a blog page from the static front page option.

Ok, thank you. I then have to live without the great slider.

Well, it’s not very hard to do if you really want it. This should be done from a child theme but I’m a little short on time at the moment to show you how. But you can edit the theme like this:

  • Appearance > Editor > header.php -> replace all content with this;
  • Appearance > Editor > slider.php -> replace all content with this.
    This will display the slider on all your pages. So the header image won’t be displayed anymore.

Thank you. But I would actually use the slider page as my “entrance” to the website. And on the following pages just have the header.And I would have the home button pointing at the slider so people always can go back to the “presentation page”. Then a button right next to the button home saying “blog” and showing the actual blogcontents with the header, menus, home button etc. Kind of hard to explain.

So why not use the static front page/blog page template in this case? You can set a static front page, hide everything on it with CSS except for the slider and the rest of your site will be with the header image and whatever content.

Thank you for your effort to explain how to make it work. I am not very familiar with CSS so I am afraid of starting changing the code. I have never tried doing a child theme either so perhaps I will just go with it as it is for now. But thank you for your help!

You don’t need a child theme, you just need to install a custom CSS plugin and use this code in the code area that the plugin provides (after you’ve set your static front page):


.home.page .site-content {
    display: none;
}

Sounds great! I will try it. Thank you.

Sorry to bother you so much but now I really want this to work since it sounds it could be done. I installed a custom CSS plugin, added the code you provided in the area (where I think it should be added).

I also set my static front page. But is that done only by choosing that option? When I choose it I get a scroll down menu but no options there I want to show at this point (I just want the slider and the button “blog” for my posts on the slider page.

I would like to attach two photos of my options but it seems I can not do that here.
Thank you for taking your time on this.

Also it is strange because when i look at your demo of the themehttp://demo.athemes.com/quill it works fine with the slider and the blog button. I don’t know if it is my webpage that is built differently since I had another theme before. And that affects when changing themes?

You should post a link to your website. If you don’t get any options in the dropdowns in Static front page then you probably don’t have any pages.

Here is the link to the website when the slider is on. If I change the option in static front page to “a static page” I can see my blog on the first page but then the slider totally disappears. When I choose “a static page” I get the two scrooldowns with front pages and posts pages and I get all my menu names there. But not the posts pages.
When you have looked at the website with the slider I can change it to “a static page” and you will see my blog on the first page (home).

You haven’t posted your link. You’re missing some stuff apparently. If you want you can send an admin account for me at vlad[at]athemes.com and I’ll set it up for you so you can see what I mean.

Oh Sorry, forgot that! http://ulrichthomsenactor.com

As you can see on the right of each page there is the content of the blog. But I can not “add” it to a button on the top menue.

Just for your info. I also created another website http://inembryothemovie.com and it is the same here. I did this from scratch so no other themes are involved or “old data”. And it is the same. I can not get the blog button on the slider on the top menu, as it is in the demo.

I’m sorry, I don’t understand anymore what you want to do. You should probably post a screenshot and draw on it.

Hmm, Ok, maybe it can just not be done. I just wanted my page to look the same as on the quill demo. http://demo.athemes.com/quill/blog/ Where there is a button “blog” on top of the slider, to the right of the “home” button. When pressing blog you enter the blog page.

My problem is I do not have the “blog” button and I do not know how to get it there.
I can see my blog content when scrolling down the slider. But would like to get there by pressing on the blogg button, as on the demo.

Well, I don’t explain very well. I will see what I can do. But thank you for your time, appreciate it. I really like the theme.

Yeah, I’m really missing something. To get a Blog button there you need to add it from Appearance > Menus.