Hyperlink to bookmark on a page

I am trying to link to a specific section on a page from another page with a hyperlink in the body of the page. But since a page in Astrid ends with a “/” directory symbol, the hyperlink doesn’t work.

So my hyperlink looks like

<code>http://www.mysite.com/mypage/#mysection</code>

which doesn’t work.

How should it be formatted?

Hello @skyline,

I will be glad to help you, but can you please provide a link to your website to let me inspect it?

Kind Regards, Roman.

The home page is at http://exactexte.com/newtheme/en/. The hyperlink is partway down the page at http://exactexte.com/newtheme/en/about/, “Click here for a free quote”

Hello @skyline,

I’ve just checked your site, the link works for me.

Have you already resolved your issue?

Kind Regards, Roman.

Nope, it works only if I open it in a new tab, it doesn’t work when I just click it.

I tried to replicate your issue on my localhost, but it works there.

Can you please try to deactivate all your plugins and see if it helps?

Please remember about importance of full site backups.

Kind Regards, Roman.

Ok, I found the problem. It was the javascript I had used earlier to add scrolling to the Call to Action button. Obviously you can’t scroll from another page, so the link became inactive. So I just added a javascript selector so the javascript only acts from that particular CTA button and now other link works.

And, yes, I do a full site backup using Updraft Plus.

Hello @skyline,

It’s great that you have found the problem!

Please feel free to ask any other questions that you might have in future.

And have a nice day :slight_smile:

Kind Regards, Roman.