How to shorten the summary in the feed display?


#1

I’m updating each post and translate it into the 2nd language.

I wonder why the introduction of these translated post will appear that long… even though I have chosen to display the feed as a summary?

how to correct this?

Click this:

https://jane10322-yahoo.tinytake.com/sf/OTUyNjNfNjM5NDYx


#2

Hi Jane, you can read that? You are genius :slight_smile:

Displaying feed as a summary doesn’t do that.

It is common problem with East-Asia languages. I came up with simple solution for you. Go to Appearance > Editor, choose content.php

Next you have to change this code inside <?php ?> which is possitioned at the end of content.php file

<div class="entry-summary">
    <?php the_excerpt(); ?>
</div>

with this one:

<?php
$excerpt = substr(get_the_excerpt(), 0, 200);
echo $excerpt . "[...]";
?>

And consider using child theme because on update you can lose these settings. Here is the link after.