How to change linked pages section link name

Hi Sydney team,

You’ve provided a great solution to one of my questions on how to link service icons to specific page sections -> How to link Service Icons to different page sections?

Everything works perfectly but once the user is taken to the specific service the link contains the page number and it does not look great.

Is there a way that I can add the specific service name instead of #pg-704-2?

For example -> https://ivalambova.com/услуги/консултиране

The website is ivalambova.com
You can find screenshots of the question here

Many thanks!

Iva

Hi,

Please modify the Row ID of the Rows you’re linking your Services, so in Page Builder Edit the Row for which you want to change the default ID like #pg-704-2 to a text ID like “something” in Attributes / Row ID enter “something”, so then you can link your service like yourwebsite.com/services/something instead of yourwebsite.com/services/#pg-704-2.

Kind Regards,
Csaba

1 Like

Hi @csaba! Thank you for your quick reply.

I do understand the logic and have changed the Row ID as shown on the ss. However, once I update the page and search in view-source I can only find the widget title as shown in the second ss.

Do you have any other suggestions on how to proceed?

Hi,

After Save, please also Publish / Save Changes on the Page too, the Row ID have to change after you enter the text there, but please clear your cache after this change and also try latin text.

Kind Regards,
Csaba

1 Like

Hi csaba,

I have cleaned my cache, changed the text to Latin, then Saved and Updated the page (the consultancy ID is visible in page source).

Then, placed the new link into Service link, Updated again but I am linked to the wrong service page rather than the one I have here -> https://ivalambova.com/my-services/

And why it is forwarding to services rather than my-services page?




Hi,

Please deactivate the maintenance mode, so I can check what’s wrong with the link.

Kind Regards,
Csaba

1 Like

Thank you, this is done now. Just note that I have included the link for the first service only.

And this is the link used for the service icon.

Let me know if you need more.

Best,
Iva

Hi,

It seems you have a redirection from my-services/consultancy to services/consultancy, please try to re-set your permalinks by removing .htaccess file from your WordPress install’s root folder then in wp-admin -> Settings -> Permalinks set your Permalinks to Plain -> Save -> Post Name -> Save, then check how it works.

Kind Regards,
Csaba

1 Like

Hi @csaba, can you send me an easy to follow tutorial for the suggestion you’ve made above?

Thanks,
Iva

Hi,

Unfortunately easier I can’t explain, it’s the easiest way that I’ve described above, but please read this guide ( it’s a bit more difficult, but more detailed ): https://www.tipsandtricks-hq.com/how-to-reset-the-htaccess-file-of-your-wordpress-site-using-ftp-8527

Kind Regards,
Csaba