Homepage widgets not showing on pages with different language

Hi there,

We’re currently setting up a multi-lingial website using your Astrid Pro theme in combination with Polylang.
However, after setting up Polylang, the homepage versions in additional languages do not show any of the homepage widgets.
Can you tell me how we can get the homepage looking the same for all selected languages (including the homepage widgets)?
Thanks for your help in advance.

Best regards,

Edwin | Uitblinkend

Hello Edwin, can you please provide a link to your website in order to let me check it?

You can use some link shortener if you don’t want to leave the link to your site in this topic.

Kind Regards, Roman.
aThemes Support

Hello Roman,

The URL is s-packs.nl. However the site is still behind a login.
Is there a way I can provide you the credentials by pm?

Kind regards, Edwin | Uitblinkend

As it turns out the automatic homepage copies are set to ‘standard template’ instead of ‘widgetized’.
Plus the homepage widgets aren’t copied at all anyway, so you have to add them to the other language pages manually, one by one.
There must be an easier way, right?

Kind regards, Edwin | Uitblinkend

Hello Edwin,

…so you have to add them to the other language pages manually, one by one.

I think that’s how you should do it, but you can try to contact the Polylang support as well and see what they say. Please feel free to ask any other questions that you might have.

Kind Regards, Roman.
aThemes Support