Home Page Sections Not Displaying


#1

Hi!

Please help! No matter what I do, none of the “Home Page Section” such as “Latest Products” or “Call to Action” are showing up on my page despite being selected under “Customization”.

A few things
-I have set my home page page to “static” and “shop”
-I have installed WooCommerce
-I have products added and they are assigned categories

I’m at my wit’s end on trying to figure out how to get this to work. Please help!

Site: www.blerdbunny.com


#2

Hi,

Please set your Homepage’s Page Template to “Front Page” in wp-admin -> Pages -> Edit Homepage and from right-sidebar under Page Attributes / Template, then it should work.

Kind Regards,
Csaba


#3

Thanks for responding! I tried to change to change the template to “front page” but even when I save it goes back to “default template” on its own…despite me saving it as “Front Page”. What should I do?


#4

Also, I tried deactivating “Elementor” and the option to select a template went away so I activated that plugin again. I’ve tried to change the template type to “Front Page” but after I publish it the system makes it goes back to “Default Template”. Is there something else I should be doing?


#5

Hi!

Just sending another update. I put in a ticket with my hosting company to see if the problem with the page template could be with the server. I figured since the page theme changes back to “default template” once published there could be some database/server problem. The hosting company checked my site and said it was an issue with the theme and I should contact you. Please let me know how I can fix this. Thanks.


#6

Hi,

Please give me an admin access to your website in a Private Message, so I can check this issue further in your wp-admin, but I guess there’s a caching issue on your server=side or you may have an issue with a Cache plugin, to check this, I must have to login to your website as Administrator.

Kind Regards,
Csaba


#7

Hi,

Thanks for your help. I thought it could be a cache issue due to my research and I already deleted the cache via the WP Super Cache plugin. I also deactivated it in hopes that was the problem. I am still experiencing the same issue with the page template changing back to “default” after I select “front page”. Your assistance is greatly appreciated with this. Thanks!


#8

Hi,

I was able to set your page’s template to “Front Page” if I have deactivated all of your plugins and deleted the cache plugin, I have also changed your homepage to “Home” instead of “Shop”, because the page “Shop” is set to be the default Shop Page for WooCommerce, please check your website setup now and let me know how it works.

Additionally I suggest to remove a few unnecessary plugins, they may cause other issues too, you have a lot of unnecessary plugins.

Kind Regards,
Csaba


#9

Hi Csaba,

Thanks for sorting this out for me. All the instructions I was reading everywhere said to set the home page to “The Shop”. Looks like I was hitting my head against the wall and you helped me figure it out. I have a few extra plugins from a previous theme I purchased so I agree they should be gone. I thought they were deactivated. I’m definitely not getting rid of the good ones like facebook pixel and yoast :wink: Thanks again for your help!


#10

Hi,

Great! You’re most welcome! You don’t have to get rid of good and necessary plugins. If you need help with anything else, please open a new topic.

Have a nice day!

Kind Regards,
Csaba


#11