Help with Polylang

Hi! Plz i need your help.
I am creating a site in localhost.
When my permalinks are set like “/%category%/%postname%/” sydney does not recognize the translation of the frontpage and the full page slider is not appear in the translated version of my frontpage.
When my permalinks set as plain, then all works fine, but i want “pretty links”. Could anyone help me?

I forgot to told you that i am using polylang to translate my site

Mano geia sou,

Seems like a Polylang question rather than Sydney; Anyway, can you check the following (when using pretty permalinks):

  1. Settings > Languages > String translations : Are “Slide title 1” , “Slide subtitle 1” and “Slider button text” fields translated in Greek, or both languages display the English text?
  2. Settings > Languages > Settings > URL modifications module: Check that ONLY
    "The language is set from the directory name in pretty permalinks" AND “Remove /language/ in pretty permalinks” have been selected

Mano hi,

Another thing is, if you have Polylang version 2.0.6, it was released today and it is really buggy.
DONT UPDATE POLYLANG TO VERSION 2.06, IT MAY BREAK YOUR SITE!
Sydney doesn’t have to do with it in any way.

Thank you for your replies. I will try yours suggestions today and i will inform you later about that. Thank you.

Finally the problem caused by the 2.0.6 update. Now i update to 2.0.7 and all works fine!

Hi,

Great! I’m glad it’s resolved! If you need help with anything else, please open a new topic.

Have a nice day!

Best Regards,
Csaba