Help getting Homepage post preview to format the same way as within post itself?

Hello, I’m using the Sydney theme for my blog. When I create a new post, the text appears perfectly as created and intended.

However, when the excerpt of the text shows up on the home page, the it is not formatted correctly. It appears almost as plain text from TextEdit on a MAC, for example.

Can you please advise how one might make the excerpt text on the homepage preview format the same as within the post itself?

Thank you.

Hello there,

To enable the full content of posts on home page, please go to Appearance > Customize > Blog options > Content/Excerpt > tick the checkbox that says “Check this box to display the full content of your posts on the home page.”

Regards,
Kharis