Header Video does not show up on select browsers

Website: Breakthroughtovictory.com

Hi, I put in a header video, and it works great… on one distinct browser. Every computer I’ve tried it on, chrome on a mac will show the video and the rest show the header image. How do I get around this, I’d like the header video to show across all browsers.

To give a few details:

I added this code to put text on top, not sure if it matters;

(function($){
      
    "use strict"
    
 
  if( $('body').hasClass('home') ) {
    
    var mainTitle    = 'Breakthrough To Victory';
    var subTitle     = 'Where Your Success and Happiness Matters';
    var buttonURL    = 'http://breakthroughtovictory.com/results-coaching/';
    var buttonLabel  = 'Learn More';
    
    var heroContent  = '<div class="slide-inner">';
        heroContent += '<div class="contain text-slider">';
        heroContent += '<h2 class="maintitle">'+mainTitle+'</h2>';
        heroContent += '<p class="subtitle">'+subTitle+'</p>';
        heroContent += '</div>';
        heroContent += '<a href="'+buttonURL+'" target="_top">'+buttonLabel+'</a>';
        heroContent += '</div>';

    $('.sydney-hero-area').append(heroContent);

  } 

})(jQuery);

As well as…

Ill give the source of the video, which i got it from http://coverr.co/

Hello Eric,

Can you please try to temporarily deactivate all your plugins except Sydney Toolbox and Page Builder by SiteOrigin, and see if it helps?

Kind Regards, Roman.

Yea it was the WP Rocket Cache plugin, is there no way I can work around that? I really like WP Rocket.

Hello Eric,

It looks like this requires close inspection, it goes beyond our support policy. As an option, you can find a reputable freelancer on Upwork for this kind of service.

Kind Regards, Roman.