Header text CTA button has stopped working

I’ve tried everything. I can’t imagine what has interfered with it to make it stop. No matter what I do in customization or stylesheet I can’t make it even hover now. It worked as it is suppose to but yesterday it just stopped and now I can’t seem to figure it out. Here is code in stylesheet;

.header-button {
display: table;
float: left;
}
.header-buttons {
display: table;
margin: 45px auto 0;
}
.header-text {
margin: 0;
color: #fff;
font-size: 52px;
font-weight: 800;
text-transform: uppercase;
}
.header-button.right-button {
position: relative;
border-top: 2px solid #fff;
border-bottom: 2px solid #fff;
border-left: 0;
border-right: 0;
color: #fff;
padding: 15px 35px;
margin-left: 30px;
}
.header-button.right-button::before,
.header-button.right-button::after {
content: ‘’;
width: 2px;
height: 160%;
position: absolute;
top: -30%;
background-color: #fff;
-webkit-transition: all 0.3s;
transition: all 0.3s;
}
.header-button.right-button::before {
left: 10%;
}
.header-button.right-button::after {
right: 10%;
}
.header-button.left-button {
background-color: #000033;
border: 3px solid #fff;
color: #fff;
}
.header-button.left-button:hover {
background-color: #fff;
border: 3px solid #000033;
color: #315B9D;
}
.header-button.right-button:hover {
background-color: #66ccff;
border-color: #fff;
color: #fff;
}
.header-button.right-button:hover::before,
.header-button.right-button:hover::after {
background-color: #315B9D;
}

NormanSalvato.com

It shows button but that is all now. I tried to remove info and text and it went away. Added it back and it came back but didn’t hover or function. It has to be something to do with something else that is interfering or overriding it. I’ve used this with no issues for many other sites.

I would also like to add just a touch of transparency to the button’s background but 1st I wan’t it working again! Thanks for your help. J

Sorry, I gave you the wrong website. This button work fine. The URL in question is;

DavisRealty4U.com

Hello there,

Don’t know if you have changed something inside theme stylesheet, but inside your page, there is an empty div with class overlay and it is covering good part of the content. You should be able to fix this with custom css code below:

.overlay {
    display: none;
}

Best Regards!

not sure what an empty div with class overlay is even. The custom CSS code didn’t work though. I really have no idea what I even messed with that could have done this. No weard tweeks. Nothing.Just things I’ve done with other sites using this theme. Nothing unusual at all. I do not even know where to look. I’m sure it is something easy or something stupid I did but I usually know what and where. This has stumped me. I have had to refresh a page or 2 that seemed to freeze a few days ago but not even that is leading me to what it could be. The only code I have really changed is the button codes above in stylesheet.

I’m only using the left button. If I can figure out what is wrong I might use the right button as well.

I never found out what happened… so I chose the nuclear option and copy/pasted a fresh copy of the original stylesheet and changed the overlay to 0.0 and redesigned the left button. On the second try it went back to normal. I guess I just sneezed and hit some random keys in the middle of the code somewhere and saved it. Oh well. When all else fails… copy paste!

Awesome! Glad that got it fixed.

Copy / past approach always work eventually.

Best Regards!