Header slider not working properly

I have added 5 pictures to the HEADER SLIDER and when the slider slides from one picture to the next one just before the next appears, it shows a picture in-between just for half a second or less. When I just added 2 pictures in the slider it works properly. The images have a low resolution of 1700px x 1100px. Any one an idea how to fix that?
Thanks a lot in advance, Tom

I am having this same problem all of a sudden maybe from this last update? I think the last update allowed child themes to work better but maybe something happened to the slider?

Let me know if there is a fix.

Hello Tom and @scottfredeman,

I will be glad to help you, but can you please provide links?

Kind Regards, Roman.

Having the same problem! Please help…
Let’s have a look at http://val4fit.club

Hi Roman, Here is a link: http://eventspaceguide.com/

You will see the glitch after the 7th slide finishes and goes back to slide #1. It also does it with the Sydney default 5 slides.

Thank you,
Scott

Hello Roman,
here is my Link :
http://tomjasny-hotels.com/
I tried with different SLIDER SPEED, same result. It just happens when you add more than 2 pictures, with 2 it runs ok. The first time it opens the webpage (with more than 2 pics) it runs ok, but from the first time it repeats the images there is something wrong.
Thanks a lot for your help in advance, Tom

Hello everyone,

Yes, it looks like a bug. I have already reported it.

Kind Regards, Roman.

Hi there,

Can we not get a short-term fix for this issue prior to a new update?

Hello ladies and gentlemen,

The issue should be fixed now.

You can download a new version of Sydney theme from aThemes.com or wait for automatic update.

Kind Regards, Roman.

Here’s a direct link to the file: https://wordpress.org/themes/download/sydney.1.25.zip?nostats=1

Sorry for the trouble.

Hi Vlad, thanks for the update, one question, how do I overwrite the old sydney pro theme with the new sydney pro theme without loosing the existing data?
Thanks, Tom

Switch to a different theme, delete Sydney, re-install and re-activate Sydney.
No data will be lost.
Or you can do it from FTP, delete the Sydney folder and add the new Sydney folder.

Roman, I have updated my site to 1.25 (twice) and the jumpy slide thing still persists. Am I doing something else wrong?
See http://methinx.ca/

@venturis: refresh the page/clear the cache from your browser. The header looks fine on your website.

So how was this resolved, I’m having the same issue. I can’t see my images that I’ve uploaded after upgrading to sydney pro. Thanks.

@Angelo Cupo: the issue from this topic has been resolved almost an year ago.

You won’t see the same images in the header slider after you switched to the pro version because it’s a different theme with different settings, as explained in the documentation. See here how to pass your settings if you have a lot of them, or please open a new topic in case you need further help.