Header image greatmag-pro

Just trying to get GM-pro to use a header image. It has all the settings via Customise, but the image never shows. Maybe I need a different theme?

Hello there,

I am sorry for the inconvenience. It seems likely be considered as a known issue. I reported it to our developer to check. Please be patience.

Regards,
Kharis

Hello there,

Sorry, I spoke to soon. Our developer said that it should be working fine as seen on his test site.

Cloudup

Please share your site URL here, so I can check what’s stopping it.

Regards,
Kharis

Hello

Thanks for that, but I am not seeing what I would like. Yes, the Background Image works fine.

But this is where I am talking about,

Hello there,

Thank you for the followup with extra details.

To move apply the background image to the site branding area and remove the default one, please follow these steps:

  1. Install and activate the TC Custom JavaScript plugin
  2. Go To Appearance > Custom JavaScript
  3. Paste the following code into the provided box

;(function($) {

  if( $('[data-bodyimg]').length ){
	
    var $bodyBg = $('[data-bodyimg]').data('bodyimg');
    
    $('.site-branding').css(
      "background-image", "url("+ $bodyBg +")"
    );
    
  }

})(jQuery)

  1. Update
  2. Add this custom CSS code into Appearance > Customize > Additional CSS:

.site {
  background-image: none !important;
}

.site-branding {
  background-size: cover;
  background-position: center center;
  background-repeat: no-repeat;
}


Let me know how it goes.

Regards,
Kharis

Thanks Kharis.

It did not work :frowning: Looking at the code I think it is trying to move the body image to the site-branding area.

here is one site I tried it on…

I am trying to get an image behind the BC-747 title.
I think the Perth theme handles that OK so I may have to change themes.

John

Hello there,

Thank you for the followup!

Have you gone with Perth? Or, do you still need an assistance on moving the header image background?

Regards,
Kharis

Hello Kharis

I think I will go with Perth theme (or something else). But at present I am trying to find out how to upgrade my single theme GreatMag-Pro license to a Developer license. Then I will likely go with Perth-pro or Sydney-pro.

Once I find out how to upgrade to Developer, I will decide.

Thanks

John.

Hello there,

Please access your account https://athemes.com/your-account/. Then click on View Licenses > View Upgrades.

Regards,
Kharis

Thanks Kharis, Done. I now have my new licences.

I would never have found that without your help.

John

OMG! I was looking for this and try…and…It works great! :smiley:

1 Like

Hi there!

I have just setup my blog a few days back using GreatMag (non-Pro version). I am unable to get the logo in the header. Kindly help.
I have looked into the Appearance -> Customize option and have tried everything possible from my side.

Here is how my header looks like:

However, I want that orange logo at the left corner that the demo theme shows. I will replace it with my icon later.

My help to myself.
Solved it by going to Site Identity under Appearances -> Customize -> Site Identity. Edited the logo and voila!!

1 Like

Grat!

Glad to know you have been able to resolve it yourself. And thank you for sharing the trick here.

Regards,
Kharis
aThemes Support