Hamburger not showing on mobile after removing font awesome

Thank you for your help with this ticket, to remove the loading of font awesome.

I didn’t realize that the hamburger was a font awesome icon.
Now, on mobile, there’s no hamburger and it’s missing showing the X sign for missing character.

I want to fix this but:

  1. I still don’t want to load font awesome.
  2. Is there any other icon in any other font, or an image, that I can use to display instead of the Hamburger from font awesome? And if there is - what do I need to do (where to plug the icon, relevant code changes, etc.)?

The website is recklaw.com

Thank you in advance.

Hi,

Newer versions of both Sydney and Sydney Pro themes use built-in SVG icons. And you may want to upgrade your Sydney Pro to the latest version.

Adding, If the new icons don’t load at your end after upgrading, perhaps you have a cache that should be flushed.

Regards,
Kharis
aThemes Support

Hi. Thank you.
I upgraded, flushed the cache, etc.
Now, the hamburger icon is not showing consistently.
If I scroll down a tad, you can see it, and then it vanishes, and so on.
You can see this issue in Lighthouse or on a real phone.

Any ideas?

Thank you again.

Hi,

Try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .site-header.float-header:not(.fixed) .btn-menu .sydney-svg-icon {
      fill: #fff;
    }

    .site-header .btn-menu .sydney-svg-icon,
    .site-header.fixed .btn-menu .sydney-svg-icon {
      fill: #000;
    }

Regards,
Kharis
aThemes Support

Looks like it’s working. Thank you!

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support