Hamburger mobile menu doesn't show the 3 lines

Hi,

The issue has been fixed a week ago, you just need to update.

Vlad

Where can I find the update to the Sydney free version that uses SiteOrigin Page Builder?

Hello there,

We moved to Elementor as it offers more flexibility along with other greater features. Sorry, we don’t have yet prepared any update specifically for SiteOrigin. Is there any usue while you’re using it? Please let us know; perhaps we could help.

Regards,
Kharis
aThemes Support

Is there an fast, easy way to export/import content from Sydney with SiteOrigin Page Builder to Sydney with Elementor?

I updated to 1.60 and flushed (and eventually disabled) al caching, but still no hamburger menu. I’ve tried the same as @bperron:

  • adding CSS:
    .site-header .btn-menu .sydney-svg-icon {
    fill: #000;
    }

  • Changing Appearance > Customize > Colors > Header > Mobile menu button

Update: never mind, I was using a child theme with a custom header.php. Needed to add this to the header.php template:
<?php sydney_get_svg_icon( 'icon-menu', true ); ?>

1 Like

I am having the same issue using a child theme. I tried adding <?php sydney_get_svg_icon( 'icon-menu', true ); ?>. When I add that line, I end up with a big black hamburger menu the full width of the screen. Is there a specific place the code needs to be added to header.php?

Hello there,

Please provide us a link to your website, so I can take a look, as perhaps we could use CSS code to fix it.

Regards,
Kharis
aThemes Support

Thanks for your help. I should have put that in the original message. http://kvi.152.myftpupload.com.

-John

Hello John,

Sorry, I missed it.

Please try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .btn-menu {
      float: right;
      font-size: 28px;
      font-family: "FontAwesome";
      color: #fff;
      text-align:center;
      width: 28px;
      height: 28px;
      cursor: pointer;
      -webkit-transition: all 0.3s ease-out;
         -moz-transition: all 0.3s ease-out;
          -ms-transition: all 0.3s ease-out;
           -o-transition: all 0.3s ease-out;
              transition: all 0.3s ease-out;
    }
    .btn-menu:before{
      content: "\f0c9";
    }

Regards,
Kharis
aThemes Support

Thanks for the reply. I was finally got to test this. Works perfectly, I just changed the float to center.

Thanks again,
-John

You’re welcome John!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support

Hi there!

I have the same problem of most of the people above, but none of the proposed solutions worked.

I tried adding ```.site-header .btn-menu .sydney-svg-icon {
fill: #000;
}
I tried changing the mobile menu button in the customize section

I also tried with the header.php, but nothing seems to work

The website is www.norem.org

any idea for other solutions?

thank you

Hello there,

Try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    .btn-menu {
      font-size: 28px;
      font-family: "FontAwesome";
      color: #000;
    }
    .btn-menu:before{
      content: "\f0c9";
    }

Regards,
Kharis
aThemes Support

1 Like

Thank you very much! that worked!

1 Like

You’re welcome @norem,

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support

I had the same issue, so for what it’s worth here’s what fixed it in my case.

The update to Sydney that converted these icons to SVGs required changes to the files header.php (for the burger menu) and footer.php (for the up arrow). After some frustrating changes to CSS that achieved nothing at all, I finally remembered that my my child theme had its own versions of these files - versions which of course lacked those changes.

Simply copying a single line from each of those files in the parent theme - the change is pretty obvious - into the child ones fixed the problem. You will also need to adjust any CSS that styles these items as the selectors are different now, as has been mentioned above.

Hope this helps someone.

(As these PHP files are in use you may need to switch to another theme while you’re editing or - as I did - upload the new versions using FTP.)

1 Like

After two hours of searching and theme update, this solution worked for me too. Thank you!

edtit: But not on all sides. Can you help me.

http://lwrs-smue.de/mitteilungen/
http://lwrs-smue.de/schulleben/
http://lwrs-smue.de/schulfamilie/
http://lwrs-smue.de/schulinfos/
and a few more

1 Like

Hello there,

Please try installing and enabling the Font Awesome plugin. Flush cache before reloading your site. Otherwise, your web browser will load cached version of your site before the changes applied.

Let me know how it goes.

Regards,
Kharis
aThemes Support

Thank you so much! With this plugin it works!

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support