Great Mag Single Categories only displaying Six posts

When using any of the A, B, or C options for Single Category posts, it will only display up to 6 posts per category, even if I set it to 20. Tried everything, I think C will only display 3 regardless.

Any suggestions, this is terribly frustrating.

Hello there,

If your changes don’t apply, there might be an active site caching that force web browser to read cached version of the page. You should flush it first and try again.


Cleared site Cache and Browser Cache, made no difference. We even added NEW Pages and the same issue arose. The new page appear, but A, B, and C and are still limiting the number of posts displayed by Category to only 6. We tried setting it to 8, 10, 15, 20 etc…made no difference.

What now?

We don’t want to take the site down and find another Theme…but will have to if this can’t resolved within the day. This shouldn’t be happening. We have tried everything. Also Style C will only display 3 articles…

we really need help with this.

We also disabled all pluggins leaving only Site Origins Bundle and Site Origin Page builder. Incase you need to know. When we click EDIT the Page, all of the posts in the category are there and they all appear on the site blog, but not under the Cataegory page. It is on WP in case you were wondering. All update including PHP etc…nothing works.

HELP!!! Please…fast

Hello there,

Do you have a screenshot of your configuration to share here? So I could replicate it in my test site.


Hello there,

I checked it and there’s no issue found. Other items are hidden in next slides which can be seen by clicking the slide navigation buttons.


I didn’t know the page had sliders, they are so light in color they are almost invisible, how can I get rid of them and just let the all of it display running down the page. Or is there a way to make them more visable, make the “Slider buttons” larger, darker?

This doesn’t work either unfortunately the way it is.

Thank you for your help, let me know if there are other options on this feature.

Best regards, Peter Combs

Try adding the below CSS code to Appearance > Customize > Additional CSS from dashboard.

    .widget .owl-nav > div {
      background-color: #e7e7e7;
      padding: 0 20px

    .widget .owl-nav > div.owl-prev {
      margin-right: 2px !important;



I tried it, and nothing happened, or maybe I wasn’t clear in what I wanted to enlarge and make darker. I’ve attached an image just in case.

Best Peter

Hello there,

Active cache in your site might force the web browser to load older version before code addition. Please flush it and reload your site.


Nothing happened,

We’ve cleared Cache on the site and our browser cache. Absolutely no effect.

We left the code on there, are you seeing a difference?

Also checked on another computer here in the office and nothing changed there either…those little < > symbols are still tiny and grey.

You can check for yourself.

best Peter

If it can’t be fixed, we dump the Theme and get another elsewhere, we’ve used Athemes on other sites and always had good luck, this one I think is a problem.


I saw your code isn’t correctly formatted. Probably you copied/pasted it from email? Now I corrected it for you. In the future you can use this tool to help format CSS code.

I also corrected the selector. Now it looks like this:



Hello Kharis,

Thank you so very much for taking care of it, I deeply appreciate it. Yes, I copied it from your eMail instead of replicating it by typing.

Have a great week and thank you very much.

Thank you,

Peter Combs

plcombs, Asian Antiques


185 Main Street


Gloucester, Massachusette 01930


PH: 978 283 3524

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.