Great Mag Pro - Mobile Navigation Not Working

My site is: virginiaclubfender.com. The main navigation menu displays 3 bars on mobile, but you cannot click on it or see the dropdown menu items. Please advise.

Thanks,
Heather

Hello Heather,

You can try to temporarily deactivate all your plugins except Page Builder by SiteOrigin, and see if it helps.

Kind Regards, Roman.

Hi Roman,

I tried deactivating everything except Page Builder, but nothing changed. Any other thoughts?

Thanks in advance,
Heather

Hello Heather,

Did you modify scripts.js file?

Kind Regards, Roman.

Hi Roman,

I never touched the scripts.js file.

Thanks,
Heather

Roman - any thoughts on what else could be causing this?

Hello Heather, sorry for the delay.

I asked our Developer to check your issue, let’s see what he says.

Kind Regards, Roman.

P. S.
I couldn’t recreate your problem on my local GreatMag Pro install, so you can create a full site backup and try to reinstall the theme.

This is so crazy. So I did some research and found that if you add 2 blog posts, the mobile navigation menu works. This is the ticket that I found the information: Mobile menu is not working. It appears that the OwlCarousel script for the latest news ribbon in the header and that script has a bug if there’s a single item (post) in the carousel. So it throws an error and that error stops other scripts from working, like the mobile menu script.

Hope this is helpful information for others!

Thanks all!

Hello Heather, you are welcome!

And thank you for sharing that, have a nice day!

Kind Regards, Roman.