Google says my site is not mobile friendly?

Hello,

I paid for the yearly fee to use the sydney pro theme and for a while now google says that my site is not mobile friendly when it shows good on my iphone. I was told that it could be to an issue with the theme. Other themes im using do not have this problem. Could it be related to the theme?

Hi,

I am sorry to hear you’ve run into an issue.

As checked, seems likely you’re still running the older version of Sydney Pro. The latest version is currently 2.1.3. I’d recommend updating it as yours is 2.1.2.

Then run your check with mobile friendly checker tool after updating. And let me know whether updating fixes the problem or not.

Regards,
Kharis
aThemes Support

Hello,

First thanks for using our theme!

No. The upgrades at screenshot are related with aThemes plans and not the theme. You can download the latest version of Sydney Pro in the “Downloads” section at the left sidebar.

We hope this helps and clarify!

Kind Regards,

Rodrigo.

aThemes Support

I downloaded the update as a zip file but how do I install it into wordpress ?

Hello,

Great!

Through FTP you can remove/delete the current Sydney Pro theme folder at wp-content/themes/sydney-pro-ii. Then, extract the latest version you downloaded in the same place (wp-content/themes/).

OBS: If you have made some change in the theme files, you should make a backup first and then replace the changes in the new theme files.

We hope this helps and clarify!

Kind Regards,

Rodrigo.

aThemes Support

Got it thank you. I installed the update, will that fix the problem im having of google saying my site is not mobile friendly?

Hello,

Great!

Please try to run the test again as my colleague @kharisblank mentioned and let us know if the issue persists or not.

Kind Regards,

Rodrigo.

aThemes Support

Hello,

At really your website is mobile friendly. The problem is that google is not being able to load the resources of your website by some reason (the CSS and JS files) as you can see when we click in the Page Loading Issues: View Details:

I think that’s probably related with the CDN you are using (secureservercdn.net) and I have two suggestions for you:

  1. Disable the CDN from your website. Let Godaddy serving your website resources and do the test again.

or

  1. Try another CDN and see the if the problem persists. CloudFlare is a good way since they have a free plan.

Please try that and let us know the results.

Kind Regards,

Rodrigo.

aThemes Support

Ok I will try that and let you know… Thank you

I disabled the CDN and it still shows the same thing?

Hello,

Seems that your files are still being served by the CDN:

Another thing you can try is use a plugin to minify and concatenate CSS and JS files. I recommend for you this plugin:

This way you will have less CSS and JS files and maybe the Google will be able to read all of your files. This is another thing you can try.

But as I said before, the CDN is still active in the inspection I did now in your website.

Kind Regards,

Rodrigo.

aThemes Support