Google map maker icon not secure, site can't be displayed in HTTPS

I have a problem similar to this https://athemes.com/forums/topic/google-map-icon-in-popup-contact-us-let-my-web-not-secure/

I mean on my contact page: https://prosid.pl/kontakt/ there is no green padlock indicating HTTPS protocol. When I turend on console it tells me that http://www.google.com/mapfiles/marker.png is not secure. Is it possible to solve it? It seems that all I need to do is to somehow change url of this icon to https but I don’t know how, or rather I can’t find this Icon URL options you guys mentioned in that thread. I have the latest version of the theme. Thanks in advance.

Hi,

We’ll handle it and I’ll let you know when it’s done.

Hi, are there any updates regarding the matter? Should I update the theme or something or maybe not yet? Thanks in advance.

Here same question - any news on that topic?

Hi, it’s been almost six months since the topic was created. Any updates on this? Or perhaps you still working on this?

Hi,

Sorry about the delay in replying, I was not subscribed to this topic. Somehow this task got lost. I’ll handle it right away and submit the update.

Okay, the new version is now available. Sorry again about the delay.

Hi, sorry for the late reply, I installed the update but it did not help. It still displays that the icon is not secure - the same error. Could you help me with this (again)?

Hi, could you help me resolve this issue?

Is there anything preventing anyone in helping me on this matter? I paid for the theme and I would like to receive help with setting it up. It is a basic functionality which should be fixed in no time, and yet after several months I did not receive any further support. Disappointing