Google Ads not showing in Firefox

Good morning,

First of all: thanks for creating a great theme! I am impressed what is included in the free version and I am going to buy the Pro-version as soon as I have solved this issue.

i am running http://www.thinkingoftravel.com/ and my problems is that Google Ads shows in IE and Chrome but not in Firefox when I am looking at the site. I use Google Publisher plugin to display the ads on my site.

My old theme displayed advertisements in all browsers and this is why I am asking this question. I have tried to find some kind of ad blocker in Firefox, but unable to do so.

Once again, thanks a lot both for a great theme and for helping with this issue.

Brgds,

Steve

Hello,

From what I can tell the way the plugin is inserting the ads code isn’t working very well with the way we achieve that short fade in effect when you access any of the pages.

I was able to fix it on my server. Here’s what you need to do:

  • go to Appearance > Editor and style.css will be opened;
  • scroll down a bit and find this and remove it:

#page {
	display: none;	
	-webkit-animation: fadein 1s;
	animation: fadein 1s;
}

Check your page and you should see the ads.

If the issue is fixed you would need to install a custom CSS plugin and add this in it because we’re probably not going to make the change in the theme, since most of our users aren’t using that plugin:


#page {
	display: block;	
	-webkit-animation: none;
	animation: none;
}

Thanks a lot Vlad!

Unfortunately, first solution did not fix the problem in Firefox. Which custom CSS plugin should I use to test step 2?

Many thanks in advance!

It didn’t fix it because you either didn’t remove the code, or you have a cache plugin in which case you should clear the cache from the plugin options. Anyway, it’s still there. Have another look please.

Also, you’ve added in your custom CSS plugin the same code that needs to be removed. You need to add the second block I posted.

Thanks Vlad, I realized I made a mistake. Instead of taking out code, I added the incorrect code because my CSS was empty.

Now I have fixed it and thank you for your support!

Hi Vlad,

In post #9947 you referenced the css change to correct the google display issue. Removing the css animation statement fixed my issue.

But removing it takes away from the function of the theme, it just load and look as polished without the fade. Is there a work around to have both the fade & get my google ads to load?

What’s strange is I have one google ad that is in a widget in the side menu that does display with or without the css edit.

BTW, ads don’t display with or without the adinserter plugin

Hi,

No, in order to also have the fade effect some JS would be required, CSS won’t be enough.

The ad that is displaying with or without the code change is probably inserted manually or with a different plugin, which behaves differently from the Google Publisher plugin.

I don’t understand the last part.