Getting "HTTP error" when uploading images, works fine with other themes


#1

Hello,

I’m having problem in uploading images to my wordpress website, whenever I try to upload an image I get “HTTP error”, when checking in console (developer tools in google chrome), I got “{my_URL}/wp-admin/async-upload.php Failed to load resource: the server responded with a status of 500 (Internal Server Error)”.

I tried several solutions I got via google, none worked for me, the following one only worked once (successfully upload 1 image) and then same problem again.
The solution which worked once:

add_filter( ‘wp_image_editors’, ‘change_graphic_lib’ );
function change_graphic_lib($array) {
return array( ‘WP_Image_Editor_GD’, ‘WP_Image_Editor_Imagick’ );
}

I later tried to switch to the default theme, and everything worked fine, switching back to “Sydney”, same problem again, so I guess it’s this theme related issue, can anyone please help?
Thanks a lot.

I have the latest “WordPress 4.6.1” and “SydneyVersion: 1.31”.

Best regards,
Miao


#2

Hello Miao,

Can you please check the following article?

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.


#3

Thank you Roman for the reply, I tried today with another PC, it works fine without me doing any those potential “fixes”, it’s so weird.
I’ll try again with my own (a Mac) when reach home and post the result here.


#4

Okay Miao,

Let me know if you need more help.

And have a nice day :slight_smile:

Kind Regards, Roman.


#5

Not back to home yet, but tested again with the PC I tested few hours ago (which worked fine for uploading images), it’s now giving “HTTP error”, it’s so weird.


#6

Hello Miao,

It looks like server issue.

Can you please contact your hosting provider and see what they say?

Maybe there are some server-side errors?

Kind Regards, Roman.