Full width posts

I’ve tried to follow a few answers for the same question for my new Moesia Pro theme but without success.

Creating a child theme (used a plugin to create it) and amending some files (archive, siderbar, single and style) yield an empty screen across all the website, so I had to revert back to the original theme.

Any help please to set my posts as full width?

Thanks

Hello there,

Thank you for contacting us about our theme Moesia Pro.

From your site’s dashboard, go to the Customize menu > Blog options > enable Full width (no sidebar).

Have you tried this?

Stay safe.
Have an excellent day :slight_smile:

Regards,
Kharis
aThemes Support

Yes I did that,
I couldn’t see any difference before and after.

Just to be clear, blog options are equal to posts?

Thanks

Hi,

Please confirm whether you have active caching or not. If you do, you should have to flush it whenever doing some changes.

Just to be clear, blog options are equal to posts?

Yes. All setting under Blog options apply on posts page that is specified under the Settings > Reading panel.

Please provide the link to your posts page if you want me to checking it directly.

Stay safe.
Have an excellent day :slight_smile:

Regards,
Kharis
aThemes Support

I’ve not enabled caching and I believe I don’t have a caching plugin
I’m new to wordpress so still under the learning curve.

Under Settings > Reading
I can see my static homepage set but there is no static posts page
should I set such a page to be as a template?

The posts page can be found here : https://www.yaniv.name/journey-reports/
There is only 1 post :slight_smile:

Hello there,

Under Settings > Reading I can see my static homepage set but there is no static posts page should I set such a page to be as a template?

You should have to enable your Journey Reports page for posts page and no need to enable any page template on that page – use default template is enough.

Regards,
Kharis
aThemes Support

I did as you advised, set journey reports to be the post page and changed the template to default.
but that didn’t changed the actual post, but only the parent page (journey reports) that hold the posts index.

My original question is how to have a full width page in the post it self
which is this one : https://www.yaniv.name/2020/08/21/the-hunt-for-the-rare-canon-eos-r5/

Hello there,

Try adding this CSS code to Appearance > Customize > Additional CSS from dashboard.

    @media only screen and (min-width: 992px) {
      .single-post #primary.content-area {
        width: 100%;
      }
    }

    /* Remove sidebar */
    .single-post #secondary {
      display: none;
    }

Please note that the last lines remove the sidebar area on the post detail page. You may want it to remain appearing if needed.

Regards,
Kharis
aThemes Support

Yes I did that,
I couldn’t see any difference before and after.

Just to be clear, blog options are equal to posts?

Yes.

Did you notice that the code above is only aimed to the post detail page?

Perhaps you want to apply for the same on the posts page. If so, try this code:

    @media only screen and (min-width: 992px) {
      .blog #primary.content-area,
      .single-post #primary.content-area {
        width: 100%;
      }
    }

    /* Remove sidebar */
    .blog #secondary,
    .single-post #secondary {
      display: none;
    }

It would be better if you could share a link to your posts, so I can take you to the right direction.

Regards,
Kharis
aThemes Support