Footers Not Displaying Correctly

Hi, I have 3 Footers in my Rocked theme but only two are displaying widgets - Footers 1 & 3. If I drag different widgets into all three footers I get Footer 1 and 3 displaying the widget but not Footer 2.

Hello there,

I am sorry I can’t experience the same issue. All widget areas on footer appear properly. Maybe there is unwanted CSS code from one of your active plugins that hides it. Please provide us a link to your website, so we can inspect it directly.

Regards,
Kharis

the website is www.illume.net.au or do you need administrator access?

I found no widgets in your footer area. Do you still have active widgets in Footer 1, 2 and 3?

Regards,
Kharis

No I removed them because they were not working. Would you like me to insert three more?

I’ve just added three widgets and all three displayed which makes me think that there are some that will work and others that don’t?

Please check your Rocked theme’s footer.php through theme editor menu and see if it appears exactly like this. Or perhaps you are running a child theme?

Regards,
Kharis

Here you go, does it look ok?

It looks OK. Please take a screenshot where you put your widgets. Perhaps you put special widgets from certain plugin. Have you tried default widgets like Meta, Search, or Calendar?

Regards,
Kharis

Here’s a screenshot of a widget I put in footer 3…

And here’s what the website looks like…


The same widget doesn’t work in footer 2 either, but it does in footer 1

Hi, do you have a reply to my message from 4 days ago?

Hello there,

I am sorry for belated response. What will happen if you insert blank text widgets to Footer 1 and Footer 2?

Regards,
Kharis

Nothing shows in Footers 2 & 3. I typed in a few lines of text and also added images to both footers but nothing shows.
If however I move the text widget out of Footer 3 (while keeping the same widget in Footer 2) and in to Footer 1 the text and images displays in Footers 1 & 2.
If I move the widget form Footer 2 (while leaving the same widget in Footer 3) and in to Footer 1, I can see the text in Footer 1 & 2. So effectively the widget shows up in Footers 1 & 2 even though the widgets are in Footers 1 & 3.
Weird.

Do you have any solutions to this issue please?

Hello there,

To display footer widgets area, Footer 1 must not be empty. If you don’t need it, you can put an empty Text widget like this.

Regards,
Kharis
aThemes Support

So are you saying that if I want to have a search bar or social profile widget in a footer I also need to have a plain text widget in there as well otherwise nothing will display?

Hello there,

Yes. I would like to say so. Actually it shouldn’t be like so. However the current mechanism requires Footer 1 should contain at least one widget. It is a bug that should be corrected by our development team. I am sorry if this confusing you.

To correct this yourself, edit the footer.php file and find these lines of code:

    <?php if ( is_active_sidebar( 'footer-1' ) ) : ?>
      <?php get_sidebar('footer'); ?>
    <?php endif; ?>

and replace it with this:

    <?php if ( is_active_sidebar( 'footer-1' ) || is_active_sidebar( 'footer-2' ) || is_active_sidebar( 'footer-3' ) ) : ?>
      <?php get_sidebar('footer'); ?>
    <?php endif; ?>

Regards,
Kharis
aThemes Support

OK, and what will that do if I insert that code? And where do I go to get to footer.php again?

It’s OK, I’ve replaced the code. Will Footers now display widgets without having to add a plain text widget?
Also, please look at the screen shot - I want to have the words Get In Touch in Footer 1 the same colour as the words in Footer 3, Recent Posts. How do I do that?
FYI, the colours of those bits of text were automatic, I didn’t choose the colour and cannot see any way of changing colours.