Font selections not applied to Header Slider

Website: www.sincitymunitions.com
Child theme of sydney-child

My configuration under Customizing > Fonts >

BODY FONTS
Roboto:400,400i,500,500i,700,700i,900,900i&subset=latin-ext
’Roboto’, sans-serif;

HEADINGS FONTS
Stardos+Stencil:400,700&subset=latin-ext
Stardos Stencil’, cursive;

The fonts, however, are not showing on the header slider or the top widget area or the body of the website.

Hello,

I’m not sure what exactly is your issue, can you please provide more details? Also you can provide some explanatory screenshots.

By the way, I’m getting limited access notice when I visit your website. Please check it as well.

Kind Regards, Roman.

Ah, yes, we had to restrict access to north America as we were experiencing a lot of DDoS attacks and fraudulent purchase attempts. I could whitelist your IP, if you would provide it.

Also, our Site header type has always been an image but that image is now not stretched across the header.
http://take.ms/h33SV

incorrect fonts on slider http://take.ms/VoRDz

As per the Customizer, the fonts for headings should be a stencil font. The header slider shows it uses both H1 and H2 fields. From the screenshot you can see that these are not in the stencil font as defined.

Below the header image, on the front page, are rows which also have H1 fields. They, too, are not showing the stencil font. http://take.ms/0ESPk

I changed the body font to Titan+One&subset=latin-ext to see if it would take and it is not changing, even after publishing changes.

Which font size is for the widget atop the home page? http://take.ms/6hYMW

Hello, thank you for additional details.

  1. My ISP provides dynamic IP, so I can’t send you some specific IP. However, I was able to check your website.

  2. I was able to change header slider heading font using the code that you mentioned in your first post of this topic on my local Sydney install. Please disable caching/minification in order to let me check the CSS and leave here a note.

  3. Please create a new topic for your header image issue to keep forum in good order and make it easier to help you.

Kind Regards, Roman.

I disabled plugin that was minifying jss and css and flushed my Cloudflare cache. Now fonts have changed to Stardos Stencil and Raleway, but do NOT change in size relative to Customizer’s sizes.

The font size in the header reduced as well. I just don’t know which font size in the Customizer relates to it.

I consider both locations to be under the same problem of the Customizer’s fonts section. Rather than opening a new ticket for the header, I think it should easily be identified as to which font size is responsible for it.

Hello,

Not all font sizes can be changed in Customize area, so please try to use the following CSS code in order to adjust your Header contact info section font size. You can add CSS code in Customize → Additional CSS section.

.header-contact {
    font-size: 16px;
}

I meant header image issue when asked to create a new topic, not header font size issue.

Kind Regards, Roman.

OK, the CSS provided does change the header contact area as needed. Thanks.

The main issue is the existing definitions in the Header Slider for H1 and H2 which are NOT changing to match the fonts and sizes I select in the Customizer.

The H1 does correctly reflect in the rows below the slider and elsewhere in the site. Just not in the Header Slider. Reminder, I am not using Crelly Slider although it is installed and active.

Those items also have their own styling in stylesheet, so please try to add this CSS code as well:

@media (min-width: 768px) {
    .text-slider .maintitle {
        font-size: 64px;
    }

    .text-slider .subtitle {
        font-size: 36px;
    }
}

Kind Regards, Roman.

I am not seeing a change in font size on my desktop view with that CSS for the slider. The font style did update to the correct fonts, just not reflecting the sizes.

Hello,

Please remove this code from your child theme stylesheet, row 35-37:

h2 {
  font-size: 14px !important;
}

Kind Regards, Roman.

Roman, you are AWESOME! That was the fix. Thanks so much!

You are welcome! :slight_smile:

Please feel free to ask any other questions that you might have in future.

Kind Regards, Roman.