Font Awesome not loading. Plugin does not work


#1

Good Day,

I was trying to use some of the newer font awesome icons with Perth Pro. I went through the forums and tried a bunch of different solutions.

I use a child theme so I tried using the info here: Icons on services, and load the icons manually basically following the directions here: https://fontawesome.com/how-to-use/on-the-web/setup/hosting-font-awesome-yourself. That didn’t seem to work.

I then tried using the plugin and updating my .htaccess with the code mentioned from in a support ticket. That didn’t work with the following message in the plugin settings:

The Font Awesome plugin has experienced a fatal error : Sorry, your WordPress server was unable to contact the Font Awesome server to retrieve available releases data. Most likely, just re-loading this page to get it try again should work. But if you’re running WordPress offline, from an airplane, or in some other way that blocks your WordPress server from reaching fontawesome, then that will block you from proceeding until you can connect successfully.

Any thoughts? Thanks.
-Ryan


#2

Hello Ryan,

I am sorry to hear you’ve run into trouble. To help me inspect what might be causing you this, please share a link to your site here.

Regards,
Kharis


#3

Hi Kharis,

I use the template on a couple of different sites. The one I was working on yesterday is for a personal site I’m putting up, but I’ve ran into the problem on my other sites too.

Here’s the link: https://parkerswedding.com/

Let me know what you think.

Thanks,
Ryan


#4

Hello Ryan,

To avoid misunderstanding, would you please confirm that you’re referring to this blank icon? Or any other else?

21

Regards,
Kharis


#5

Hi Kharis,

Yes, I’m referring to that blank icon. But overall, I removed most of the icons that weren’t showing up when I was trouble shooting. Icons not showing up has been a consistent problem of mine. Thanks.


#6

Hello there,

I found class name of “user-friends” available in the Fontawesome version 5.x, which isn’t be used in the current version of Perth Pro.

As an alternative solution, I made a friends icon with Fontastic service. You can implement it to your site by adding this function to your child theme’s functions.

    add_action('wp_head', 'perth_pro_child_load_custom_fonticon', 999);
    function perth_pro_child_load_custom_fonticon() {
      ?>
      <link href="https://file.myfontastic.com/LdVXBUwhL6dw9KuWQvqaek/icons.css" rel="stylesheet">
      <?php
    }

If you don’t want to run a child theme, you can use a plugin that allows functions addition like Functionality or Code Snippets.

Edit your event. In the icon option, enter my-icon-font-friends class name.

27

Regards,
Kharis


#7

Hi,

That doesn’t really solve my problem. There were other fontawesome icons I would like to use, that I removed since they weren’t showing up. Is there a way to update the fontawesome version used with my theme?

Regards,

Ryan M. Parker