Font Awesome isn't working

Hi,

I’m setting up a history and services section for my website but I can’t get any of the Font Awesome icons to show. Best I get is an outlined circle.

Thanks,
Megan

Hello there,

Please share one of the Font Awesome class name you used, so I can try and check if there’s incompatibility issue.

Check with your hosting support department to inspect if there’s CORS issue in server level.

Regards,
Kharis

Hi Kharis,

fa-glasses and f530 are examples of what I have tried.

I have just checked these setting are already set.

Hello there,

I tried and found no issue with the theme because it’s displaying as it should.

16%20AM

I feel I need to inspect your site directly to find out what’s exactly stopping ti. Please share a link to your site here.

Regards,
Kharis

Hi Kharis,

The icons are faulting in the our principles section of this page.

http://tangiblebranding.com/about-us/

Thanks,
Megan

Hello Megan,

Try loading FontAwesome version 5.x with this snippet:

    function sydney_child_add_fontawesome_cdn() {
    	?>
    	<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous">
    	<?php
    }
    add_action('wp_head', 'sydney_child_add_fontawesome_cdn');

    function sydney_child_loads_font_awesome_script() {
       // Remove Font Awesome from main theme
       wp_dequeue_style( 'sydney-font-awesome' );
    }
    add_action( 'wp_enqueue_scripts', 'sydney_child_loads_font_awesome_script', 999 );

Add it to your child theme’s functions.php file. Or use a plugin that allows adding extra functions like Code Snippets.

Regards,
Kharis

Hi Kharis,

This has worked perfectly, thank you for all of your help!

You’re welcome! Glad to hear and happy to have an opportunity to help.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis

I’ve added this snippet to my page, but Elementor has not updated with the new icons in Font Awesome. Am I doing something wrong? I’ve added the Snippet via Code Snippets.

-Eleni

Hello there,

I replied you already on your another thread. Let me know if it does anything.

Regards,
Kharis