Featured image size differences on two sites

Hi,

Love the theme and recently set it up on an old site after installing it on a new site. I have a slight issue, or more kind of wondering about the featured image. Here’s what’s happened and really sorry for the long post!

On the new site and also on a few locally run test sites using MAMP, I changed the functions.php to remove extra thumbnails and images being created. It’s all worked perfectly on the test and live sites.

This is what I changed the lines in the .php file to:

    add_theme_support( 'post-thumbnails' );
add_image_size( 'greatmag-medium', 768, 432, true );
add_image_size( 'greatmag-single', 768 );

This is great for me because it creates just the one image (I create each image with that 768 x 432 size) and there’s no other thumbails or images produced, just the one. The image in wp-content/uploads also shows just the one image & on the site the featured image is all fine at all sizes when resized, etc. Checking the css in an inspector shows that the url for the image is something like this: image.jpg.

When it comes to my old site, I’ve set up the theme exactly the same and with the same plugins, but when I upload an image, it’s creating two images now: one is the original with the filename (as an example) image.jpg, but it’s also creating another one called image-768x432.jpg and this one is what is being used instead of the one with just the name image.jpg.

I’m just kind of wondering why it’s doing it on the old site but all fine on the new site. It kind of makes sense that it would create a filename, and use that file, with the image-768x432.jpg, but why wouldn’t it on the new site and on the local test sites?

I’m thinking it must be something with the old site, but I’ve disabled all plugins and tried cleaning up the WordPress database, etc.

Any help is greatly appreciated.

I should probably put links to the sites, but is it possible I can do this privately?

Many thanks,

Salem

Ahhh… I found out what was wrong. On my old site, cPanel had ‘optimisation’ on (I can’t remember turning it on but probably did, but it was disabled on the new site since I didn’t change much of the settings on the site’s cPanel except for php stuff. Disabled optimisation on the old site’s cPanel and now the issue above is all fine and dandy and my one image is now what’s being uploaded.

Cheers!