Featured image on pages too big


#1

Dear Developers (Vlad) :),

I have set the featured image size to small in the appearance/customization page and it displays correctly for posts. For pages though, it is huge.

Is there a way around this?

Many thanks!


#2

Not really sure what you mean. Could you post a link?

The option there referrs to image sizes on the blog index, not on single posts or pages if that is what you’re asking.


#3

Ah, that may be what I am asking.

Here’s where the page lives: teszt.peterfabri.co.uk – I use this to try out different settings before I implement them on my live site.

So if you check the homepage with the default post you can see that the featured image is nicely sized and on the left-hand side of the content. But if you click on the sample page where I set the same featured image, it’s on top of the content and much too big.

… so the featured image size in the options is for the index only and has nothing to do with this?

Many thanks,
Peter


#4

Correct, that option refers only to the index.


#5

… and do you know if/how could one set a featured image for a page to appear in a similar fashion to how it appears on a post?

It isn’t strictly related to moesia, I know… sorry.


#6

Exactly the same. You also need to activate it from Customize > Single posts/pages > Check this box to show featured images on pages


#7

Ah, merci beaucoup!


#8

Hmm… I have enabled that option but the image still displays as it did beforehand.

It there anything else I could try to make it appear on the left as a nice, small image just like it is next to a post?

Many thanks,
Peter


#9

I’m confused. Were you not asking about single pages before?

Let’s go through this again:

  • the small images option only works for the blog index;
  • single posts and single pages only display the images (big images) on top of everything else, in case you activate the options to display them;
  • if you’re not pleased with them being too big on single posts and single pages, than simply deactivate the checkboxes I told you about before so they won’t show up;
  • if you choose not to display featured images, you can simply add your images straight into your post or page and resize it to whatever size makes you happy.

#10

Dear Vlad!

Many thanks for your patience on this. I think I simply misunderstood the purpose of featured images, it is much clearer now.

I have to say that support here on aThemes is outstanding. Even though I don’t really need the extra features of the Pro version I’m going to buy it. Simply because I am so pleased with the level of support you guys provide. I’m a non-profit, so I might only go ahead next month but I am certainly buying it.

Many-many thanks!
Peter


#11

We aim to please :slight_smile: