Featured image: auto-scale

Hello,

a few days ago I asked how to implement the featured-image in full-width.
this works perfect, but wordpress seems automatically size-down the featured image.
Which means: I upload an image, set it up as featured, Worpress resizes it smaller, and places it in full width. Therefore the set image is pixeled:


The implemented image has even a new name with the small size:

700x350 was added automatically.

Do you have a solution for this issue?

Thank you
Sebastian

Hello Sebastian,

It looks like you have to increase astrid-large-thumb size, by default it’s set to 700px of width.

Please check these topics:



Just use astrid-large-thumb instead of astrid-client-thumb/west-large-thumb.

Please feel free to ask any other questions that you might have.

Kind Regards, Roman.

unfortunately this had no impact…

Hello Sebastian,

Did you regenerate your thumbnails after applying the PHP code?

Kind Regards, Roman.

yes :slight_smile:

Okay Sebastian,

Can you please describe what exactly you did?

Kind Regards, Roman.

I put the snippets you wrote into the Snippets plugin, changed the two mentioned code-parts into astrid-large-thumb, saved it and regenerated the thumbnails with the plugin you mentioned in the other topic.

Hello Sebastian,

It looks like this issue requires close inspection, this goes beyond our support policy. As an option, you can find a reputable freelancer on Upwork for this kind of service.

Kind Regards, Roman.

okay, maybe this is a solution:
can I display the featured image only on the main-page but not on the content-page?
so I could put it on the project-pages by hand…

Hello Sebastian,

Please try to use the following CSS code in order to hide (not remove) it there.

You can add CSS code in DashboardAppearanceCustomizeAdditional CSS (WordPress 4.7 and up). Also you can add CSS code directly to style.css file of your child theme.

body.page-template-single-service .single-thumb {
    display: none;
}

Kind Regards, Roman.