Fatal error on website

Hi

my website (www.cardiomiopatiaipertrofica.info) is not working anymore
it say
Fatal error : Cannot redeclare sydney_set_import_files() …

I contacted the host provider and they told me that tle problem is the theme
could you please help me ?
thannks

gianni

Exact same error here with 2 customers, started at about the same time as OP.
This is what debug says:

Fatal error : Cannot redeclare sydney_set_import_files() (previously declared in /home/officetech77/domains/officetech.be/public_html/wp-content/plugins/sydney-toolbox/demo-content/setup.php:18) in /home/officetech77/domains/officetech.be/public_html/wp-content/themes/sydney-pro-ii/demo-content/setup.php on line 27

Please advise, I have 2 customers that are impacted.

Cedric

Gianni (and support) - it is an update issue.
Steps to resolve:

  1. Log into your site via FTP
  2. go to the wp-content/themes folder
  3. RENAME sydney-pro-ii (just add a - after)
  4. Log in to sites wp-admin
  5. Update Sydney toobox, sydney theme AND Elementor if needed.
  6. Go back to FTP and reset the name for the sydney-pro-ii folder (just remove the - after)
  7. refresh website.

Worked here for both clients.

It is a mistake caused by bad admin behavior on our side. If we had updated everything on time this wouldn’t have happened.
Lesson learned.

I have the same problem on Sydney Pro (www.verticalrio.com). Contacted the host and they say there’s a problem with the Theme. On Wordpress admin it says “This theme is broken. This theme failed to load properly and was paused within the admin backend.”

Fatal error: Cannot redeclare sydney_set_import_files() (previously declared in /home/verti695/public_html/wp-content/plugins/sydney-toolbox/demo-content/setup.php:18) in /home/verti695/public_html/wp-content/themes/sydney-pro-ii/demo-content/setup.php on line 27

Helle Athemes Support,

I received this message today from Wordpress. What are the necessary steps I need to take to fix this?

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with your theme, Sydney Pro.

First, visit your website (https://www.reflectivewisdom.com/) and check for any visible issues. Next, visit the page where the error was caught (https://www.reflectivewisdom.com/wp-login.php?jetpack-sso-show-default-form=0) and check for any visible issues.

Please contact your host for assistance with investigating this issue further.

If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely login to your dashboard and investigate further.

https://www.reflectivewisdom.com/wp-login.php?action=enter_recovery_mode&rm_token=bXrA8hmeWsV3FK6YBy9USW&rm_key=1HxOWuf51I81Bl301V5AeE

To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

When seeking help with this issue, you may be asked for some of the following information:
WordPress version 5.3.2
Current theme: Sydney Pro (version 1.51)
Current plugin: (version )
PHP version 7.3.13

Error Details

An error of type E_COMPILE_ERROR was caused in line 20 of the file /home1/facetso5/public_html/reflectivewisdom/wp-content/themes/sydney-pro-ii/demo-content/setup.php. Error message: Cannot redeclare sydney_set_import_files() (previously declared in /home1/facetso5/public_html/reflectivewisdom/wp-content/plugins/sydney-toolbox/demo-content/setup.php:18)

Hello there,

I am sorry for the inconvenience and please accept my apolpgies for this.

It was function conflict between latest version of Sydney Pro and Sydney Toolbox plugin. We have fixed it and updated the Sydney Toolbox.

If you still can’t access your site’s admin area, please do the below steps:

  1. Access your site’s folder over FTP client program;
  2. Go to root_folder/wp-content/plugins directory;
  3. Delete permanently the sydney-toolbox folder;
  4. Login to your site’s admin area (/wp-admin);
  5. Instal and activate the Sydney Toolbox from plugin installer’s search menu (Dashboard > Plugins > Add New).

Let me know if you still experience any issue with it.

Regards,
Kharis
aThemes Support

Hello,

The issue is already fixed, please update the Sydney Toolbox plugin once again. Sorry for the inconvenience.

Kind Regards, Roman.
aThemes Support

Hi

now the website is working but I lost some of the formatting (for example menu footpage etc), could you please help me to restore it?

thanks

gianni

How did you configure this? Did your footer look exactly like on our demo site’s footer?

Regards,
Kharis
aThemes Support

Hi

could you please help?
thanks
gianni

Hello Gianni,

Please create a new topic for your issue in order to make it easier to help you.

Kind Regards, Roman.
aThemes Support

Hi,

I had the same issue and removed the toolbox via ftp. Installed it again and everything seem to be working. After activating the toolbox I ran into the same problem ‘The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.’
Deleted it again and the site worked Installed again, but still deactivate and it had the problem again. doggygroom.co.uk/wp-admin. The site seem to be working fine when it is istalled but can’t access admin unless toolbox is deactivated. Is this a plugin I have to have or can I just delete it for good?

Hello,

Please update your Sydney theme as well after making a full site backup.

Kind Regards, Roman.
aThemes Support

Sir ,after completing all processes given by you I am still facing problems this please help

Fatal error : Cannot redeclare sydney_set_import_files() (previously declared in /home/powerg5d/public_html/wp-content/plugins/sydney-toolbox/demo-content/setup.php:18) in /home/powerg5d/public_html/wp-content/themes/sydney/demo-content/setup.php on line 22

There has been a critical error on your website.

Learn more about debugging in WordPress.

After completing all processes given by you I am still facing problems this

Fatal error : Cannot redeclare sydney_set_import_files() (previously declared in /home/powerg5d/public_html/wp-content/plugins/sydney-toolbox/demo-content/setup.php:18) in /home/powerg5d/public_html/wp-content/themes/sydney/demo-content/setup.php on line 22

There has been a critical error on your website.

Learn more about debugging in WordPress.

Please help

Please update the theme first after you do the 4th step.

Regards,
Kharis
aThemes Support

I am using the free version and I also have got the error:
Fatal error : Cannot redeclare sydney_set_import_files() (previously declared in /home1/dcinetv/public_html/wp-content/plugins/sydney-toolbox/demo-content/setup.php:18) in /home1/dcinetv/public_html/wp-content/themes/sydney/demo-content/setup.php on line 20

I have a child theme folder named “sydney-child”
I don’t have access to (misite/wp-admin) site is crashed.
I deleted my old “sydney toolbox” like your instructions say. My site worked again. But then when I installed the “sydney toolbox” (shows the plugin was updated 4 days ago), my site crashed instantly.
Now I am locked out.
I have access to FTP.
Could you please help me out? This is a high traffic site with google addons, etc…

Thanks.

Hello there,

Please log into your FTP account and follow these steps:

  1. Access your site’s folder over FTP client program;
  2. Go to root_folder/wp-content/plugins directory;
  3. Delete prmanently the sydney-toolbox folder;
  4. Login to your site’s admin area (/wp-admin);
  5. Update the Sydey theme
  6. Instal and activate the Sydney Toolbox from plugin installer’s search menu (Dashboard > Plugins > Add New).

Regards,
Kharis
aThemes Support

Yes, I did this all. I am afraid to download the new sydney theme (free), because I don’t know how to “upgrade” it from the current one that I have install. I will loose things in the header code.
I have a child theme, I don’t know how it will affect it when I “upgrade” the 2020 free Sydney theme.
Please help me with these questions.
Thanks.

When main theme gets updated, the code in your child theme will remains.

Regards,
Kharis
aThemes Support

1 Like