Employees Widget

Hi, I’ve a couple issues with the Employees Widget:

  1. I tried to enable the custom link for the Employess widget based on:
    https://athemes.com/forums/topic/employee-custom-link-not-working/
    I modified the mentioned php file inside the theme’s folder (I also made a backup of the file in my local pc) and also checked the types for the “custom-link” section and it is all there and the link is not working. Also, suddenly everytime I add the employees plugin everything stops working and I get a pop up instead that says: “Basic Dialog” as title and “Dialog” as content. And the rest of the page stays blank. I replaced the original source for the file, but still have the same problem. The employees widget is not working anymore and I couldn’t make the custom-link work.

  2. Translation:
    I’m using the WP-Globus plugin for multi language support. I can’t figure out yet how to translate the “Title” of the any Moesia Plugin. It doesn’t provides the additional tab for the corresponding translation.

My website’s URL is:
http://devops.ec

Thanks in advanced for your help.

Hello there,

Thank you for reporting.

> 1

While you’re editing the template file, try to enable the debug mode. Edit the wp-config.php file, change define( ‘WP_DEBUG’, false ); to define( ‘WP_DEBUG’, true ); It will help you to find in which line the error comes from. Please refer here.

> 2

Apologies, I can’t clearly get the point. What do you mean by “Title” of the any Moesia Plugin? Could you please elaborate that?

Regards,
Kharis

Hi Kharis,

You may refer to the following link so you can get an idea of the error I get when I get the employees widget:

I already set the debugging option to true in the mentioned php file. Where is the output redirected to? screen? Unfortunately still see no debug info.

As for the translation:

Have a look at the following image:

There’s only one option for title textbox and it says “Nosotros” so it shows as the plugin’s header in spanish.

Now, have a look at the following image:

You’ll notice there’s a “English” tab that allows me to translate a given text.
I don’t have that option in the first image I showed you.

Thanks in advanced for your help.

Giancarlo

Hello Giancarlo,

Thank you for updating me.

What will happen if you completely delete the current active Moesia Pro theme then reinstall the fresh one?

Regards,
Kharis

Hi Kharis, is there any other alternative? If I go down that path I’ll have to reconfigure the entire website (colors, menus, widgets, etc)

Maybe just reinstall the employees widget?

Thanks,

My bad… Just deleted the theme and downloaded it again from my account (moesia-pro-ii.zip). The problem persists. I’m getting that weird alert “Basic dialog” instead of my main page every time I add the employees widget.

Thanks,
Giancarlo

Got rid of that dialog problem. Now the employees widget is showing, but still the custom-link is not working.
Can you give me a hand with this issue?

Thanks,
Giancarlo

Dear Giancarlo,

Try to do the following:

  1. Open the widgets/fp-employees.php file.
  2. Replace the following lines

<?php if ($photo != '') : ?>
  <img class="employee-photo wow zoomInDown" src="<?php echo esc_url($photo); ?>" alt="<?php the_title(); ?>">
<?php elseif ( has_post_thumbnail() ) : ?>
  <div class="employee-photo wow zoomInDown"><?php the_post_thumbnail('moesia-employees-thumb'); ?></div>
<?php endif; ?>

with


<?php if ($photo != '') : ?>
  <?php echo ($custom_link != '') ? '<a href="'.esc_attr($custom_link).'">' : ''; ?>
	<img class="employee-photo wow zoomInDown" src="<?php echo esc_url($photo); ?>" alt="<?php the_title(); ?>">
  <?php echo ($custom_link != '') ? '</a>' : ''; ?>
<?php elseif ( has_post_thumbnail() ) : ?>
	<div class="employee-photo wow zoomInDown">
    <?php echo ($custom_link != '') ? '<a href="'.esc_attr($custom_link).'"' : ''; ?>
    <?php the_post_thumbnail('moesia-employees-thumb'); ?>
    <?php echo ($custom_link != '') ? '</a>' : ''; ?>
  </div>
<?php endif; ?>

Let me know how it goes. I’ll wait to hear back from you regarding your stats.

Regards,
Kharis

Thanks Kharis for your help. The code provided worked fine.