Employees widget again


#1

Hello everyone,
I’m Xavier from SCARPI, trying to create a french site with an english version. I turned to WP and this beautiful piece of theme that is Sidney. Great work guys !
My concern: as the type “employee” did not quite fit my purpose, I modified it to “accompagnateur” (i.e. mountain leader in french) and created two items of this type (for myself and my colleague).
The employees widget did not work. Then I tried to add a category “accompagnateur” and edited the widget with the slug for this category with no more result.
So I come for some way to work it around and, since I would like to do the same thing for the local vegetable growers and other producers that work with us, may be for someone to explain me from the scratch how I can create a different type than “employee” and stil benefit from the employees’ widget to have the beautiful layout.
Thanks in advance everyone.


#2

Hello Xavier,

You can change the widget title (when editing your front page) and employees slug in Types plugin settings to “accompagnateur”.

If you want deeper modifications, then you will most likely have to edit at least widget .php file. But this goes beyond our support policy. It’s considered advanced customization.

As an option, you can contact Codeable for this kind of service, or find a freelancer on Upwork.

Kind Regards, Roman.

P. S.
I think that your GR 20 Veg image is too large, its dimensions are 2600×3306 pixels.


#3

Hello Roman,
thanks a lot for the answer (and the image tip).
I’ve already tried what you described as in the two images below.
Employees widget settings

To try to debug I then highlighted the widget with a blue color and the row with a darker green. As you can see on the website www.scarpi.fr there is only a darker green area just beneath the GR20Veg image (where I wanted to put the widget).

What am I doing wrong?


#4



#5

Just to be sure, here’s my type “accompagnateur” summary:


#6

Okay Xavier,

I suggest you to reimport Types settings and make only one adjustment, change the slug by going to Types -> Post Types -> Employee.

I hope that it will help you.

Kind Regards, Roman.


#7

Thanks a lot for the help Roman, the first step worked with the re-import. I’ll try tomorrow to see if I can make it fit my needs (with sub-types of employees).


#8

You are welcome Xavier,

Please let me know if you need more help.

Kind Regards, Roman.