Employee layout

Hi!

I am employees setup on their own individual pages, so I have a row with 2 widgets, the left side being the “employee widget” with profile picture of the employee, and the right side being “text widget” which has their bio. And I have the ratio set to even. Problem is this:

  • The picture is too small, its showing up at about 132 x 132 px. I would like it to size closer to 200x200 or 235x235 px. And thats only when I have the ratio set to even. When I would prefer to have the column with the photo to be smaller than the column with the text. But also to have the picture sizing larger than it it. How would I go about doing that?

And my other question is that none of the Employee info is showing up, only the name and title. I added custom URLs as I read from directions from another persons forum.

I have read through a lot of the forums and saw that some of the changes you have sent to others have been by editing .js code. I am using a child theme and I have a .css styles page which I have been working on as well as the functions.php (which I have not edited yet) If the solution to my sizing is going to be any .js edits, would I be putting that into the .css or .php file that I already have setup in my child theme? Or will I have to create a new file? And if the code that I need to add is php, do I just put that code directly into my child php file?

Thank you SO much for all of your help!!

Hi,

The size of the employees photo is small because there are padding which wrapping the employee widget.

Could you please to post the URL of your site? so I can help you further and in the right point.

By the way, I have to merge your similar question to here.

Hello there,

Thank you for asking.

> Change the image size

  • Try to edit widgets/fp-employees.php file
  • Change the following line
<?php the_post_thumbnail('sydney-medium-thumb'); ?>

to

<?php the_post_thumbnail(array(200,200)); ?>

This size will be applied for all employees images. You can’t have different size for particular ones.

As you will edit the core theme’s file, you should take it at your own risk. The changes you have done will be overridden once the theme get updated in the future.

To insert extra custom JS and CSS scripts, I’d suggest you to use Header and Footer Scripts plugin. So that you don’t have to touch the child theme’s files.

I hope this reply helps.

Regards,
Kharis

Hi!

Thanks for your response! Here is my site: http://themattnadergroup.com

Is there a way to edit that widgets file on a child theme or on another file so that I don’t edit the themes core file and that so when I do an update the changes won’t be overridden?

You can duplicate “widgets/fp-employees.php” into your child theme and start editing the file in there.

After the file is modified, then:

  • open functions.php in your child theme and add this line:
if ( function_exists('siteorigin_panels_activate') ) {
  require_once get_template_directory() . "-child/widgets/fp-employees.php";
}
  • activate your child theme, it will display an error message
  • open functions.php in the parent theme and change this line:
    require get_template_directory() . "/widgets/fp-employees.php";
    to
    // require get_template_directory() . "/widgets/fp-employees.php";

Oh boy… Blank pages!!

So I copied the fp-employees file into my child theme.
I changed the line that you said to in the child fp-employee file… this step:

<?php the_post_thumbnail(‘sydney-medium-thumb’); ?>

to

<?php the_post_thumbnail(array(200,200)); ?>

Then I downloaded the regenerate thumbnails plugin and did the regenerate.

Then I hit update and then I went to click on the functions.php file in my child theme and all went blank white pages.

Help Please!!!

Now it seems like my whole site is down! Yikes!!

Hi,

You missed this steps:
– activate your child theme, it will display an error message
– open functions.php in the parent theme and change this line:
require get_template_directory() . "/widgets/fp-employees.php";
to
// require get_template_directory() . "/widgets/fp-employees.php";

Ok, but I can’t even get to that part now. Or any part of my dashboard. All I get is white. I can’t even login to my dashboard. I cleared my cache and everything. Something has totally messed with my site Im really worried!

You edit using wordpress editor? It’s not recommended if you edit the PHP files from wordpress editor. I suggest you to edit the file using FTP or using editor in CPanel

Can you login using FTP or CPanel? If so, please do the last step in above from the FTP or CPanel

I did all of those steps just now in control panel on blue host and i still am getting nothing but white and can’t even get a login :frowning:

The error is because re-declaring the function of the widgets in the functions.php within the child theme.

Please try to remove this line below from the functions.php in your child theme:

if ( function_exists('siteorigin_panels_activate') ) {
  require_once get_template_directory() . "-child/widgets/fp-employees.php";
}

If your site still blank, you can send me the cpanel login details to my email, so I can help you to fix this.

Ok… So I changed my plugins folder name in my control panel and that opened everything back up again. So I guess I need to figure out which one it was that shut me down?

Your site gone blank or error because you add this line to the functions.php in your child theme:

if ( function_exists('siteorigin_panels_activate') ) {
  require_once get_template_directory() . "-child/widgets/fp-employees.php";
}

And to fix the error, you have to open functions.php in the parent theme and change this line:
require get_template_directory() . “/widgets/fp-employees.php”;
to
// require get_template_directory() . “/widgets/fp-employees.php”;

Ok, so now I started reinstalling my plugins one by one, and the one that shut me down again was the page builder plugin, which obviously I need to have. What can we do about that?

Can I send you my wordpress login information and have you take a look at it? I tried reinstalling the page builder plugin and it shut me down again :frowning:

There should not related with the plugin, it was the child theme.

you can send me the login detail to awan.rimbawan101 at gmail

Ok, I just sent you my login. You have no idea how much I appreciate all of your help!!! Thank you so much!!