Emergency! Pages went blank


#1

Love the theme, but had two “HOME” links on the navbar, so I attempted to specify a customized menu…and the home page (among other pages) has gone blank.

See it at my site.

Several other pages went blank - interestingly, all the pages where I’d migrated content from my prior template (Fine Pro) into the Page Builder editor.

However, since this happened, I’ve experimentally migrated content on other pages into the Page Builder editor, and those pages are displaying just fine.

I tried reverting to the prior template and then re-activating, to no avail.

I’ll leave the site in its present condition for a few hours, but I’ll have to revert ASAP.

If you’ve got a solution, please suggest a fix for the two “HOME” links, if you could, too…

Thanks!


#2

Okay, I found the issue: Your Masonry Portfolio plug-in. Firebug found an error in reading the Isotope js file. Bug? Looks like a lovely, clean solution. I’ll try to re-upload, since the plugin isn’t in the WP approved gallery, to my knowledge.

Menu selection is now working properly, for some reason.


#3

Hey,

I had a look at your site and everything sees to be in order now?
What error are you getting from the Isotope script? Perhaps there is a conflict with another plugin that is using the same script. The plugin itself is as simple as a plugin of this type can get, so it can hardly cause any issues.


#4

I deactivated Masonry, so the site is working, but the error I got was simply what Firebug told me: there was a problem reading the Isotope JS file. The result was that the page wouldn’t load.

Is the extension available on the WP approved plugins page yet?


#5

There might be a conflict with one of your other plugins. The plugin itself works, I mean I can show you examples of it working on various sites. If you ever feel like it, you can activate it and try deactivating some other plugins so you can find the one that there is a conflict with.

We didn’t submit it to the WP repository. I don’t think there is much point in doing that since there are already more complex similar plugins. This is just meant to be an easy solution for Moesia users.


#6

You nailed it - conflict with a responsive gallery plugin I forgot to deactivate. Looking forward to getting this up and running!


#7

Spoke too soon. Here’s the shortcode I was using. Only “All” and “Content / SMM” show up as filters, and the Projects I have tagged as “Content / SMM” don’t show up at all.

[moesia-masonry posts=“10” show_all_text=“All” post_type=“projects” filter=“yes” include=“Content / SMM,Websites & Online”]

I’ve tried deleting spaces, adding space, etc., in the shortcode, to no avail.

If I turn off the filters, the post still doesn’t appear. However - posts will appear if I set it as…

filter=“yes” include=""]


#8

It does say on the documentation page that include="" must contain the slugs for the categories you want, comma separated as you can see there. What you’ve added there are not slugs so the posts will show up without a filter because there is nothing to build the filter from.

Can you tell me the name of the plugin which is causing the conflict? Maybe something can be done about it.


#9

Thanks for the clarification. D’oh! Working perfectly now. The plugin that was causing the issue was Responsive Gallery Grid, by Jules Colle. Didn’t take much hunting even for a newb like me to figure out another gallery plugin might be causing a conflict…!


#10

So are you still going to use that plugin? I didn’t test but I think the solution would be simple in case you plan to use it.


#11

No, I’m not going to use Responsive Gallery Grid. Having Masonry working makes it superfluous.