Elementor not working

Hello

I have a WEBSITE, but when trying to edit my page with Elementor plugin, there is no possibility to do so, the “Edit with Elementor” does not even show.

Everything was fine until today, when I installed 404 plugin and created a 404page. I tryed to disable the 404 plugin, cleared the Cash, tryed to Delete elementor plugin and installed it back again, bur nothing changes.

I checked my cPanel and everything is installed, I have a valid SSL certificate. Even when I go to Admin Dashboard / Pages there is no possibility to edit the site with Elementor. And when i go to Admin Dashboard / Pages under Page Attributes / Template, there is no Elementor Canvas etc. options, only Default, Front page, Full page.

I tryed all of these → Elementor Help Center steps and nothing worked.

Also the pages are all made as Static, but the 404page shows as Post page…

Thank you for your help & Best regards,
BR

Hi,

I am sorry to hear that you’ve been into an issue. I am happy to help out.

To check whether the theme is causing you such this issue, try testing with one of default WordPress themes like Twenty Twenty-One. To do this securely in private mode, you can enable troubleshooting mode with this help of this plugin.

I’d request giving it a try and let me know your views.

Regards,
Kharis
aThemes Support

I tried it with Twenty Twenty-One theme, and it did not work.
I tried to disable Preloader via Additional CSS (I read another writing of yours about the same issue).
My hosting data is all up to date, my other Sydney + Elementor sites with the same hosting and on the same system are working fine.
I tried disabling all the plugins.
I tried to delete and again upload Elementor. Cached the site in between.
Tried to change from false to true in my wp-config file.

I tryed all of these → Elementor Help Center steps and nothing worked.
I even created a new subpage and there is no Elementor.
I tried to edit the page in different browsers - Chrome, Microsoft Edge, Internet Explorer (all are up to date), and nothing.
I tried to downgrade Wordpress from version 5.7.2 to 5.7.1 and 5.7, and Elementor version from 3.2.5 to 3.2.0 and still nothing.

And still, Elementor does not want to show itself to me :slight_smile:

Thank your Kharis for your time,
BR

Hi,

Thank you for getting back.

I think I should inspect the trouble directly from your site’s admin area.

If you don’t mind, please share the temporary admin login link to kharis@athemes.com.

Ensure to do these before sharing the link:

  • Set the link expiry to 7 days
  • All administrator rights are enabled
  • Enable troubleshooting mode with this plugin

Regards,
Kharis
aThemes Support

1 Like

I did as you said…

Thank you for your time and help Kharis;
BR

Hi,

I didn’t receive your email. Can you resend it again – as perhaps you wrote my email address incorrectly?

Regards,
Kharis
aThemes Support

I have sent it again, I hope you got it.

Best regards,
BR

Hi,

I got the link. Thanks!

As checked, Elementor editor hadn’t yet been enabled for any post type under the Elementor settings page (Dashboard > Elementor menu > Settings).

I enabled for page and now you have a new button at the top of the edior to switch to Elementor editor screen when adding a page.

I can confirm it is not theme-related issue.

Regards,
Kharis
aThemes Support

Thank you Kharis.

It was probably the 404 plugin problem. I tried to deactivate it when I tested the site and nothing changed. I deleted the plugin and installed a another 404 redirect plugin, and with your help and changes made (as seen above in your comment), my site is now working as it should.

So if anyone has the same problem, try to delete the 404 plugin (not only deactivate it), and install another 404 redirect plugin, and allow temporary admin login for the site inspection (see above how to share…).

Thank you Kharis & Best regards,
BR

1 Like

You’re welcome!

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis
aThemes Support

1 Like

Hello kharisblank

I am having again some problems with Elementor, ufter update, with another of my WEBSITES.

When I loged in there was no Edit with Elementor possibility. I clicked Clear cache on one of my SUBPAGES and then on that subpage the Post part showed, and prior to that I did not have a post page allowed.

Every page now has the possibility to Edit with Elementor, except the 404 page, that page does not show as it is.

*UPDATE:
Resolved A): I went to my SUBPAGE that showed the Unwanted “Post part” on the right side. I went to the page settings and for some reason, after last Elementor and WP update it was not set anymore Page Settigns / Layout / Elementor Full Width, but it was blank. Now the subpage is at it should be.

The problem still is that my 404 page does not show nor allow the Edit with Elementor.I tried to deactivate my 404 plugin but the same problem is still there. Now I activated the plugin back.

Thank you for your help & Best regards,
BR

I deleted the 404 page and now I created a new page. The page shows the sign Edit with Elementor, but when I try to edit it it shows an error window:

“The preview could not be loaded
error 404”

The page also does not show correctly in preview and live view, it does not show the text.

Thank you for your help & Best regards,
BR

Hello @Manager_Slo,

That’s really strange. In the others pages the Elementor is working, right ? The only way in this case is doing a inspection directly from your website (like @kharisblank did in the previous replies). Could you please generate a link and send to my email ?

rodrigo@athemes.com

So we can inspect your WP install and see what’s happening.

Kind Regards,

Rodrigo.

aThemes Support

I just did. Thank you @rodrigo

Hello,

Thanks for the access!

The culprit of the issue is the 404 plugin. But fortunatelly, there’s an option inside the plugin that make the things work:

OBS: I already checked and saved the Activate Compatibility Mode in your website.

We hope this helps!

Let us know if you need further help.

Kind Regards,

Rodrigo.

aThemes Support

Thank you @rodrigo, the site is working as it should.

You nailed it, thank you for your quick reaction, your help and time.

Best regards,
BR

Hello,

You are welcome!

If you are satisfied with our theme and support, would be great if you leave your comment and rating in the offical WordPress Themes repository. That helps us a lot: [Sydney] Reviews | WordPress.org

Let us know if you need further help.

Kind Regards,

Rodrigo.

aThemes Support

1 Like