Elementor doesn't load


#1

Hi,

I can’t work on my front page because when I click on “Elementor mode”, Elementor do not load…
(sorry for my english)
My website (asso-soka.fr) has a maintenance mode but even when I disable it, it doesn’t work, so it’s not the problem.
I try to delete Elementor and install again but no success.

Thanks for your help,
Anne-Sophie


#2

Hello there,

Ensure you’re running the latest versions of WordPress, Elementor and Sydney theme. Also please check if your server meets these minimum requirements. You’d contact your web hosting department.

If those are fine, the issue might be caused by one of your active plugins. Try disabling all extra plugins temporarily and run your Elementor editing. To find out the source of the issue, try re-enabling them one by one.

Regards,
Kharis


#3

Hi,

I’m the web hoster for asso-soka.fr.
Actually, server is running Apache 2.4, MariaDB 10.3 et php-fpm 7.2.

I was wondering if using fpm could be a problem ?

Other point, website is behind a pfsense+haproxy, which one is managing SSL, could that also be a problem ?

Jerome
Core Us


#4

I have some strange behaviour, results …

Elementor syste summary says that I only have 40MB php memory limit. In fact, memory limit is set at 128MB.
I can’t find where this value come from.

I also found these errors :

SecurityError: Blocked a frame with origin "https://asso-soka.fr" from accessing a cross-origin frame.
		at https://asso-soka.fr/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.2.5 - 2:94037
		2018-10-29 12:57 +00:00
		x 4 times

	SecurityError: Sandbox access violation: Blocked a frame at "https://asso-soka.fr" from accessing a cross-origin frame.  The frame being accessed is sandboxed and lacks the "allow-same-origin" flag.
		at https://asso-soka.fr/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.2.5 - 2:94036
		2018-10-18 15:27 +00:100:

I can’t figure if the problem comme from my firewall/load-balancer or somewhere else.


#5

Not really sure about PHP FPM could cause you this issue. But before inspecting it further, please check if it’s an issue with Sydney theme by temporarily disabling it and use one of default WordPress theme.

For server config related issue – that really out of the theme’s code, you could consult to this channel on WP.org support.

https://wordpress.org/support/forum/installation/

Regards,
Kharis


#6

Hi

All other wordpress that I host run well. Only this one with Elementor and Sydney have trouble.
If it was related to servers configuration, it would happen on almost all of them.

regards


#7

Hello there,

Have you tried it with default WordPress (like Twenty Seventeen) enabled?

Regards,
Kharis


#8

Hi,

Yes I tried but did not work.
Here is the thread I’ve open on wordpress forums :
https://wordpress.org/support/topic/cross-origin-frame/

Actually, I cannont test anymore cause they choose to use another builder.

I’ll try to reproduce problem as soon as possible and keep you informed

regards
Jerome


#9

I saw in the .org support channel you mentioned about cross origin issue. To fix it, try to follow the below blog post.

Regards,
Kharis