Editing Sydney Header Slider

Hello,

I’m using a header slider for my Sydney theme website that circulates two images.

As you know, each image has a title and subtitle.

Here is my question:

Can you tell me how to make the first image title an h1 and the second image an h2?

Thank you very much in advance for your guidance.

Hi Jack,

You’ll need a child theme to edit the main slider code. If you haven’t yet created any, you can use our premade Sydney child theme. In the functions.php file of child theme, you’ll need to insert this code to override the default slider. Then replace this line:


<h2 class="maintitle"><?php echo esc_html( $titles['slider_title_' . $c] ); ?></h2>

with:


<?php if( $c == 1 ) { ?>
  <h1 class="maintitle"><?php echo esc_html( $titles['slider_title_' . $c] ); ?></h1>
<?php } ?>

<?php if( $c > 1 ) { ?>
  <h2 class="maintitle"><?php echo esc_html( $titles['slider_title_' . $c] ); ?></h2>
<?php } ?>

Save changes. Zip/archive the child theme folder, then install and activate.

Regards,
Kharis

How do i access the premade child theme?

Download it and then do editing in your computer. Please follow this instructions to install a child theme on your site.

Regards,
Kharis

Thank you for assisting me with my Sydney theme.

I updated my website with the new child theme as directed. Unfortunately I have encountered problems. Putting those off topic issues aside, my Header Slider is still showing up as <H1>, <H1> when analized for SEO.

Now that the child theme is installed can you instruct me specifically how to convert the titles for the two images in my Header Slider from <H1> to <H2>?

I have been looking in the Slider.Php but this appears incorrect. Please advise

Thank you.

Hi Jack,

Have you properly done this instructions?

Regards,
Kharis

To the best of my knowledge I have executed as instructed. I sent you the modified code for you to review.

The child theme also triggered a strange overlap betweem image number one in the the child thee and image number one in standard Sydney.

Addtionally, all Sydney Theme widgets and custom fuctions have vanished from my site.

The CTA buttons that were installed contained a warning sign in the editor that said “missing” and when I went to the widget library all Sydney products were gone. Perhaps this was caused by the most recent wordpress update? In any regard I had to work around this using other widgets without having solved the original issue.

I am still fixing these problems today. Any guidance is appreciated

Kharis,

Thank you very much for all your help and extra attention. The collateral issues my site suffered were caused by updating to sydney 1.37 and resolved by updating to 1.38.

Concerning your patient and detailed advice about the duplicate <h1> tags in my slider header, you hit the nail on the head. It’s now working. I am extremely grateful.

Thank you most kindly for all of your assistance.

You’re welcome, Jack.

Please let us know in a new topic if you have any further questions, or if we can provide you with any other assistance.

Regards,
Kharis

Hi Kharis,

A few months ago you supplied me with a child theme for my free sydney theme website. www.jackrourke.net
However, since programing is outside my area of expertise, I do not understand the instructions for installing this child theme.

Are there simpler instructions? Or is there any way I can get direct assistatnce installing a child theme into my site?

Thank you