Disable Header not working on blog page

I seem to be dealing with a bug. When I set a page as the blog page (Appearance >> Customize >> Static Front page >> Posts Page: the header image shows, even when Disable Header is selected.

On other pages it is working as intended. If I unselect the same page as the Posts page, the header disappears as it should.

My development site: http://128.140.220.130/~pafh384723/ I have set the Blog 2 page as the blog page. (the other page called Blog, is a normal page with a Blog module from Live Composer)

Hello there,

Basically the page which has been assigned as a posts page won’t behave like a regular page anymore. Thus header image visibility option which is associated to it always be ignored. You should manually hide the header image by adding the following CSS code through the Simple Custom CSS plugin or child theme’s style.css.

.blog .site-header{
  background-color: #1c1c1c;
}

 .blog .site-header.header-scrolled{
  background-color: rgba(255, 255, 255, 0.9);
}

.blog .header-image{
  display: block;
  height: 0;
  overflow: hidden;
}

.blog .site-content{
  padding-top: 80px;
}

Regards,
Kharis

Thank you!

Is this also the way that this page http://demo.athemes.com/west/blog/ is set up? Or is there a simpler solution (with Live composer) that I overlooked?

Thanks,
Joost

On our demo site, “Only menu” is being active on the below path:

Appearance > Customize > Header area > Header type > Site header type

Meaning that other pages have no header image. So it doesn’t need custom CSS like what I’ve suggested previously.

There is no simpler way with Live Composer, I am afraid.

Regards,
Kharis