Custom link problems

I have a custom link in menu for “About Us” with http://www.khorshidnoor.com/#pg-8-9 url. This menu item great work when click it in Front Page, but when click it in another pages like my Blog page or from another site by link, another section of Front Page is shown! What can I do?!

I tested everything and found something. When “Page Builder by SiteOrigin” plugin is activated, custom link from other pages has problem. But when I deactivate that plugin, custom link work from anywhere but other things have problems! What can I do now?!

Thanks
Best Regards
Kaveh

Hello Kaveh,

You can try to put your About Us block above your Testimonials block because testimonials can change page height and it potentially might cause such issue.

Kind Regards, Roman.

Hi Roman
I do what you said! But nothing changed, please test again.

Thanks
Kaveh

Hello Kaveh,

Well, your About Us link seems to be working from blog and employees page now. Can you confirm that?

Kind Regards, Roman.

Hello Roman

No, did not work in blog and employee pages in windows browsers like firefox and chrome, just seems to be working in firefox mobile version!
Thank you for checking.

Regards, Kaveh

Hello Kaveh,

Well, I don’t think that there is an easy way to resolve it.

As an option, you can create a separate About Us page.

Kind Regards, Roman.

Hello Roman

Thanks for your help, I know I can create a separate page but in one page is better and more beautiful, but at the end I must do it if I did not find a solution, thanks again.

Best Regards, Kaveh

You are welcome Kaveh,

Kind Regards, Roman.