Custom ID jump in some cases does not jump to right position

Hi there,

Tried to get response from Live Composer but they referred to the West Theme since the feel it could be in your area…

My problem:

I have made a few custom ID’s in the rows in LC, e.g. for the menu items Wie we zijn en Contact. They link to resp.

https://www.waterlely.nl/#wie-we-zijn
and
https://www.waterlely.nl/#contact

And from the homepage whenever you click those, they end up perfectly at the right spots. But when you click to them from the Blog page https://www.waterlely.nl/blog/ something strange happens.

From the blog page to Wie we zijn: no problem.
But from the blog to Contact: It first jumps to contact as it should, but then a second later is jumps to Laatste Waterlely Artikelen… the blog items on the home page.

Any ideas?

Greets,
Olaf

Hello Olaf,

Can you please try to temporarily remove video and full width photo, and see if it helps?

Kind Regards, Roman.

Hi Roman,

I will try later. The site is live now si I can’t try live and I don’t have time now bring up a test environment.

Let you know if it works later.

Greets,
Olaf

PS: with full width image do you mean the header of the images later on the page or all?

Hello Olaf,

By “full width photo” I mean full width image in page body.

Kind Regards, Roman.

Hi Roman,

I’ve tried this locally with wamp but the behaviour is the same.

I have a video of my site without the Video content and the Full Width image where you can see it.

I’ve uploaded it to https://www.waterlely.nl/wp-content/uploads/2016/12/Contact_Jump.mp4

Greets,
Olaf

Hello Olaf, thank you for the video.

Can you please try to install Surbma – Smooth Scroll plugin?

If it won’t help, then try to deactivate all plugins except recommended.

Please make a full site backup first and/or try on localhost.

Kind Regards, Roman.

Hi Roman,

Unfortunately no effect.

Strangest thing though is that jumping to all of the other links from the blog works just fine. Only the one for contact does not.

I’ve tried (locally) to reposition the Contact row but no effect. It seems it has to do with the Ninja Form itself I think. Maybe because it has to load or something. It jumps to the right position and then half a second later it jumps half a page.

And the reason that does not happen on the home page is because then it has been already loaded on the background.

So a workaround might be that when the Contact link gets clicked from outside the homepage that the jump must be adjusted to end uup higher on the page than from the homepage…

No clue how, however :slight_smile:

Greets and thanks so far,
Olaf

Olaf, did you try that link with Ninja Forms plugin deactivated?

Kind Regards, Roman.

Good suggestion!

Tried just now, but actually to my surprise that didn’t work either.

See https://www.waterlely.nl/wp-content/uploads/2016/12/Contact-Ninja.mp4

Any other ideas? I ran out… really hoped this was it.

Greets,
Olaf

Olaf, what about moving Contact section to separate Contact page? Is it an option for you?

Kind Regards, Roman.

Not really, I like the way it works right now a lot better than with a separate page.

But for now it works good enough. Only from the blog you end up wrong, but then one click on contact again or a little scroll will do the trick as well.

Thx for your effort.

Okay Olaf, you are welcome.

Please let me know if you need more help.

Kind Regards, Roman.