CSS not showing in most browsers


#1

Hi,
I’ve built my site: popupnairobi.com but it’s having compatibility issues with almost everything- CSS isn’t showing up. It’s working on some smartphones, and on my computer: Windows 7 and latest Firefox and Chrome, but not latest IE, when checking on browser comp websites nearly all only show the HTML.

I built first on popupnairobi.com/wordpress so maybe I screwed something up when changing to popupnairobi.com

Does anyone have any ideas? I’m new to this, so I’ve no idea if it’s a theme issue I can fix, or hosting issue.

Thanks so much.
Cheers,
Nicole


#2

Hello,

You messed something up in there. It doesn’t load any CSS on Chrome as far as I can see. And you’re not running Moesia anyway. Try reinstalling Wordpress and reinstalling the theme and make sure everything in Settings look alright.


#3

Hello,

You messed something up in there. It doesn’t load any CSS on Chrome as far as I can see. And you’re not running Moesia anyway. Try reinstalling Wordpress and reinstalling the theme and make sure everything in Settings look alright.


#4

Hi,
This is the thing, I am running Moesia, and it turns up fine on some browsers and not others. The sub pages turn up with the URL: eg http://popupnairobi.com/a-school-kitchen/

If I reinstall wordpress and the theme do I lose all my work?

Thanks,
Nicole


#5

Could you please clear your cache from the WP Super Cache plugin? I think that might be causing the issues. On your front page you don’t have Moesia code.


#6

Hi Vlad,
Thanks for the help, I had my index.php in the wrong spot on my hosting.

Now it’s nearly all running well, but doesn’t resize well for smaller screens/phones. Is there a certain image size I should be using for backgrounds for parallax to work properly? Or somewhere I can put in alternates?
[Eg, on a small screen the background of ‘what makes us smile’ isn’t long enough, so the grey background shows instead. On my ipad (ipad1 i think) their is no parallax effect.]

Also, there is a big white gap before the services section (what we do on my page), I can’t find where this is in the editor?

THanks for all your help!!
Best,
Nicole


#7

They do work properly. It’s just that the parallax effect is removed on smaller screens. Obviously, some of them cannot cover your whole section on small screens because they don’t have enough height.

The gap is the padding of the widget. If you add each widget on a row there will be a border between them and it will look like it’s supposed to.